summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/ssdeep')
-rw-r--r--app-crypt/ssdeep/ssdeep-2.13.ebuild25
1 files changed, 19 insertions, 6 deletions
diff --git a/app-crypt/ssdeep/ssdeep-2.13.ebuild b/app-crypt/ssdeep/ssdeep-2.13.ebuild
index 718d5f7f8667..44711c713cf0 100644
--- a/app-crypt/ssdeep/ssdeep-2.13.ebuild
+++ b/app-crypt/ssdeep/ssdeep-2.13.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-AUTOTOOLS_AUTORECONF=1
+EAPI=6
-inherit autotools-multilib
+inherit autotools multilib-minimal
DESCRIPTION="Computes context triggered piecewise hashes (fuzzy hashes)"
HOMEPAGE="http://ssdeep.sourceforge.net/"
@@ -16,6 +15,20 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static-libs"
-DOCS=( AUTHORS ChangeLog FILEFORMAT NEWS README TODO )
+DOCS=(
+ AUTHORS ChangeLog FILEFORMAT NEWS README TODO
+)
-PATCHES=( "${FILESDIR}"/${PN}-2.10-shared.patch )
+PATCHES=(
+ "${FILESDIR}/${PN}-2.10-shared.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf
+}