summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/mailcrypt')
-rw-r--r--app-emacs/mailcrypt/Manifest1
-rw-r--r--app-emacs/mailcrypt/files/50mailcrypt-gentoo.el1
-rw-r--r--app-emacs/mailcrypt/mailcrypt-3.5.9.ebuild42
-rw-r--r--app-emacs/mailcrypt/metadata.xml8
4 files changed, 52 insertions, 0 deletions
diff --git a/app-emacs/mailcrypt/Manifest b/app-emacs/mailcrypt/Manifest
new file mode 100644
index 000000000000..233b6fd9c831
--- /dev/null
+++ b/app-emacs/mailcrypt/Manifest
@@ -0,0 +1 @@
+DIST mailcrypt-3.5.9.tar.gz 172073 SHA256 a195e1e56db44519945861900c6a11c787fc28482d939d5a7564a0f0b900e054 SHA512 df6524ecc42d4c7bdddb34439186690192bc4091a1965e405223106fc71047c33e4bbbd571b030c326efec46961ba0aefd018ff1205d230dc74c34daf93ba079 WHIRLPOOL 19e7cceb7e1cc400e53165f21355ab501e0712f9d3da23cc81569a440bf20ef0d423ffbc7a5f4a9a00271fc3bccae2a322bbdf89a717aae55dea38a071865d5b
diff --git a/app-emacs/mailcrypt/files/50mailcrypt-gentoo.el b/app-emacs/mailcrypt/files/50mailcrypt-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/mailcrypt/files/50mailcrypt-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/mailcrypt/mailcrypt-3.5.9.ebuild b/app-emacs/mailcrypt/mailcrypt-3.5.9.ebuild
new file mode 100644
index 000000000000..6892efcf44c5
--- /dev/null
+++ b/app-emacs/mailcrypt/mailcrypt-3.5.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp autotools
+
+DESCRIPTION="Provides a simple interface to public key cryptography with OpenPGP"
+HOMEPAGE="http://mailcrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mailcrypt/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+RESTRICT="test"
+
+RDEPEND="app-crypt/gnupg"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ export EMACS=/usr/bin/emacs
+ econf
+}
+
+src_install() {
+ emake \
+ lispdir="${D}${SITELISP}/${PN}" \
+ infodir="${D}/usr/share/info" \
+ install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc ANNOUNCE ChangeLog* INSTALL LCD-entry NEWS ONEWS README*
+
+ DOC_CONTENTS="See the INSTALL file in /usr/share/doc/${PF} for how
+ to customize mailcrypt."
+ readme.gentoo_create_doc
+}
diff --git a/app-emacs/mailcrypt/metadata.xml b/app-emacs/mailcrypt/metadata.xml
new file mode 100644
index 000000000000..d6d654a5d70b
--- /dev/null
+++ b/app-emacs/mailcrypt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="sourceforge">mailcrypt</remote-id>
+</upstream>
+</pkgmetadata>