summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/sparsehash')
-rw-r--r--dev-cpp/sparsehash/Manifest1
-rw-r--r--dev-cpp/sparsehash/sparsehash-2.0.4.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-cpp/sparsehash/Manifest b/dev-cpp/sparsehash/Manifest
index 01962c61fa6f..d06575060229 100644
--- a/dev-cpp/sparsehash/Manifest
+++ b/dev-cpp/sparsehash/Manifest
@@ -1 +1,2 @@
DIST sparsehash-2.0.3.tar.gz 322046 BLAKE2B 3749875bfbfa0ec9b92cfe68496a318208539745ca1b76910193879cb9ac790952b390cfbd941ff6e9714bd61546844e8f2d958d9b24845efeb54743facac136 SHA512 bb00d0acb8eba65f7da8015ea4f6bebf8bba36ed6777881960ee215f22b7be17b069c59838d210551ce67a34baccfc7b2fed603677ec53c0c32714d8e76f5d6c
+DIST sparsehash-2.0.4.tar.gz 323154 BLAKE2B 8e0da89a6ae684271293f048092d6c79d14818f7ab9d4fa449414b3354f9e7769d9b0cc724227c47a1be7c7357cdac5cf6f3873047a08c8f085cc457858a8826 SHA512 40c007bc5814dd5f2bdacd5ec884bc5424f7126f182d4c7b34371f88b674456fc193b947fdd283dbd0c7eb044d8f06baf8caec6c93e73b1b587282b9026ea877
diff --git a/dev-cpp/sparsehash/sparsehash-2.0.4.ebuild b/dev-cpp/sparsehash/sparsehash-2.0.4.ebuild
new file mode 100644
index 000000000000..88d2a4fe1b87
--- /dev/null
+++ b/dev-cpp/sparsehash/sparsehash-2.0.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="An extremely memory-efficient hash_map implementation"
+HOMEPAGE="https://github.com/sparsehash/sparsehash"
+SRC_URI="https://github.com/sparsehash/sparsehash/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+S=${WORKDIR}/${PN}-${P}
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0.3-fix-buildsystem.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}