summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/drift/drift-2.2.3.ebuild')
-rw-r--r--dev-haskell/drift/drift-2.2.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/drift/drift-2.2.3.ebuild b/dev-haskell/drift/drift-2.2.3.ebuild
new file mode 100644
index 000000000000..ef4bb38730e2
--- /dev/null
+++ b/dev-haskell/drift/drift-2.2.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base ghc-package
+
+MY_PN="DrIFT"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Preprocessor for automatic derivation of Haskell class instances"
+HOMEPAGE="http://repetae.net/john/computer/haskell/DrIFT/"
+SRC_URI="http://repetae.net/john/computer/haskell/DrIFT/drop/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=("${FILESDIR}"/${PN}-2.2.3-ghc-7.4.patch)
+
+src_configure() {
+ econf --with-hc="$(ghc-getghc)" --with-hcflags="${HCFLAGS} -package haskell98 -hide-package base"
+}
+
+src_compile() {
+ # Makefile has no parallelism
+ emake -j1
+}