summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/uniplate')
-rw-r--r--dev-haskell/uniplate/Manifest1
-rw-r--r--dev-haskell/uniplate/metadata.xml35
-rw-r--r--dev-haskell/uniplate/uniplate-1.6.12.ebuild35
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-haskell/uniplate/Manifest b/dev-haskell/uniplate/Manifest
new file mode 100644
index 000000000000..aac16986f82e
--- /dev/null
+++ b/dev-haskell/uniplate/Manifest
@@ -0,0 +1 @@
+DIST uniplate-1.6.12.tar.gz 30055 SHA256 fcc60bc6b3f6e925f611646db90e6db9f05286a9363405f844df1dc15572a8b7 SHA512 049b07e8a57db7e44d91fc9c8dcfb5c49b78a692a730061763cb8bcc4fbc3ed1065bd7a4c337e3d344693df882a0718b6d3bb6a6ea1e7d520a36d252d7038b07 WHIRLPOOL d44c14e7c913496ff3d7802847e265efc29e1cc4283887268c86230f24e59f93e435ffa4f16ee6c081cd9bbfffbba4d351c3f7e5688697c2e6a8098ba037d722
diff --git a/dev-haskell/uniplate/metadata.xml b/dev-haskell/uniplate/metadata.xml
new file mode 100644
index 000000000000..97b35877856d
--- /dev/null
+++ b/dev-haskell/uniplate/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Uniplate is library for writing simple and concise generic operations.
+ Uniplate has similar goals to the original Scrap Your Boilerplate work,
+ but is substantially simpler and faster. The Uniplate manual is available at
+ &lt;http://community.haskell.org/~ndm/darcs/uniplate/uniplate.htm&gt;.
+
+ To get started with Uniplate you should import one of the three following
+ modules:
+
+ * &quot;Data.Generics.Uniplate.Data&quot; - to quickly start writing generic functions.
+ Most users should start by importing this module.
+
+ * &quot;Data.Generics.Uniplate.Direct&quot; - a replacement for &quot;Data.Generics.Uniplate.Data&quot;
+ with substantially higher performance (around 5 times), but requires writing
+ instance declarations.
+
+ * &quot;Data.Generics.Uniplate.Operations&quot; - definitions of all the operations defined
+ by Uniplate. Both the above two modules re-export this module.
+
+ In addition, some users may want to make use of the following modules:
+
+ * &quot;Data.Generics.Uniplate.Zipper&quot; - a zipper built on top of Uniplate instances.
+
+ * &quot;Data.Generics.SYB&quot; - users transitioning from the Scrap Your Boilerplate library.
+
+ * &quot;Data.Generics.Compos&quot; - users transitioning from the Compos library.
+
+ * &quot;Data.Generics.Uniplate.DataOnly&quot; - users making use of both @Data@ and @Direct@
+ to avoid getting instance conflicts.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/uniplate/uniplate-1.6.12.ebuild b/dev-haskell/uniplate/uniplate-1.6.12.ebuild
new file mode 100644
index 000000000000..cb51d2e99f90
--- /dev/null
+++ b/dev-haskell/uniplate/uniplate-1.6.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: +separate_syb,+typeable_fingerprint
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Help writing simple, concise and fast generic operations"
+HOMEPAGE="http://community.haskell.org/~ndm/uniplate/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hashable-1.1.2.3:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ dev-haskell/syb:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.1:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=separate_syb \
+ --flag=typeable_fingerprint
+}