summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/pomap')
-rw-r--r--dev-ml/pomap/Manifest3
-rw-r--r--dev-ml/pomap/metadata.xml8
-rw-r--r--dev-ml/pomap/pomap-3.0.2.ebuild31
-rw-r--r--dev-ml/pomap/pomap-3.0.3.ebuild31
-rw-r--r--dev-ml/pomap/pomap-3.0.5.ebuild31
5 files changed, 104 insertions, 0 deletions
diff --git a/dev-ml/pomap/Manifest b/dev-ml/pomap/Manifest
new file mode 100644
index 000000000000..43f29c70dc19
--- /dev/null
+++ b/dev-ml/pomap/Manifest
@@ -0,0 +1,3 @@
+DIST pomap-3.0.2.tar.gz 69919 SHA256 44e9a7ca73fc8a11ffccaed65444e1cf67b1ccb2737f942bd6a99f6ceb743e0c SHA512 cbf239023c0861fd076895c45c9fb05e9794af4ecab913a5a0fbba188ed1c52a8f880ffe66dda0845863a31e30cd34f40add872abe0135c79467dda6c429423f WHIRLPOOL aec4f2aec45ae2768d43c8e14b7d515dd0a6ac841c9b11a402499f1bfc2f825e06102826ca6437fcad0830ea6356fae9bc50d62651d5c9b7873764b84e9d4c05
+DIST pomap-3.0.3.tar.gz 73040 SHA256 ff35571fb06230d4448ec61d57dc46d38019ceba1e650600c7eedf26590a5256 SHA512 f0a3d1dcbd8cbcffebaaa4fb4d59fe8bc439a689c67b34c3653e9142934265081a65fcab132f0ad5933cdc4f9b0eb776018e3b0df8762c7e5ba7dc61a0021d42 WHIRLPOOL f4d1ef0287583321a3bed8ad1612cb9babcfabe7694afb148f650a4ffdf509f0acd1327ab6ed0058609776904a22ddab3a91339eecf130dd4dabdc56b7b3410c
+DIST pomap-3.0.5.tar.gz 74574 SHA256 9788da1550dd88557262e91f4cd3f8c216b2b66ad0d3a2c7e65734177e5f87c2 SHA512 7b3700a7afd10dc0cbdc58086f27ed69b58b10776b6be9a268fa1a96f45f9af68c733f0939674325a415a55670875d1bb3d05ff562aa3ab9ae3a44822c13ddf4 WHIRLPOOL cc195567b7313ed20d6281fdfe775e2f9f6d5d58d2005a609505b5db18468d4885aa4e51608348d611e34961871d21de9935687667f9f8865c764f945ea39700
diff --git a/dev-ml/pomap/metadata.xml b/dev-ml/pomap/metadata.xml
new file mode 100644
index 000000000000..58b8f62421ba
--- /dev/null
+++ b/dev-ml/pomap/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <upstream>
+ <remote-id type="github">mmottl/pomap</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/pomap/pomap-3.0.2.ebuild b/dev-ml/pomap/pomap-3.0.2.ebuild
new file mode 100644
index 000000000000..343e225d8acb
--- /dev/null
+++ b/dev-ml/pomap/pomap-3.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Partially Ordered Map ADT for O'Caml"
+HOMEPAGE="http://bitbucket.org/mmottl/pomap"
+SRC_URI="http://bitbucket.org/mmottl/pomap/downloads/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-ml/pomap/pomap-3.0.3.ebuild b/dev-ml/pomap/pomap-3.0.3.ebuild
new file mode 100644
index 000000000000..48431c8f4da8
--- /dev/null
+++ b/dev-ml/pomap/pomap-3.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Partially Ordered Map ADT for O'Caml"
+HOMEPAGE="http://bitbucket.org/mmottl/pomap"
+SRC_URI="http://bitbucket.org/mmottl/pomap/downloads/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+
+DEPEND="|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-ml/pomap/pomap-3.0.5.ebuild b/dev-ml/pomap/pomap-3.0.5.ebuild
new file mode 100644
index 000000000000..766dfe89ecb9
--- /dev/null
+++ b/dev-ml/pomap/pomap-3.0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Partially Ordered Map ADT for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pomap/"
+SRC_URI="https://github.com/mmottl/pomap/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+
+DEPEND="|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}