summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/sexplib/sexplib-0.9.2.ebuild')
-rw-r--r--dev-ml/sexplib/sexplib-0.9.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/sexplib/sexplib-0.9.2.ebuild b/dev-ml/sexplib/sexplib-0.9.2.ebuild
new file mode 100644
index 000000000000..8ea3c1e31504
--- /dev/null
+++ b/dev-ml/sexplib/sexplib-0.9.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Library for automated conversion of OCaml-values to and from S-expressions"
+HOMEPAGE="https://github.com/janestreet/sexplib"
+SRC_URI="https://github.com/janestreet/sexplib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc"
+IUSE=""
+
+RDEPEND="dev-lang/ocaml:="
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_test() {
+ jbuilder runtest || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md README.org
+}