summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Test-Warnings/Test-Warnings-0.26.0.ebuild')
-rw-r--r--dev-perl/Test-Warnings/Test-Warnings-0.26.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Test-Warnings/Test-Warnings-0.26.0.ebuild b/dev-perl/Test-Warnings/Test-Warnings-0.26.0.ebuild
new file mode 100644
index 000000000000..d197411771dd
--- /dev/null
+++ b/dev-perl/Test-Warnings/Test-Warnings-0.26.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.026
+inherit perl-module
+
+DESCRIPTION='Test for warnings and the lack of them'
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test suggested"
+
+# Test::Builder -> perl-Test-Simple
+RDEPEND="
+ !<dev-perl/File-pushd-1.4.0
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-Test-Simple
+ virtual/perl-parent
+"
+# File::Spec::Functions -> perl-File-Spec
+# List::Util -> perl-Scalar-List-Utils
+# Test::More -> perl-Test-Simple
+DEPEND="
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ ${RDEPEND}
+ test? (
+ suggested? (
+ >=dev-perl/CPAN-Meta-Check-0.11.0
+ )
+ >=virtual/perl-CPAN-Meta-2.120.900
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.108.0
+ virtual/perl-if
+ virtual/perl-version
+ )
+"