summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cffi/cffi-1.12.3.ebuild')
-rw-r--r--dev-python/cffi/cffi-1.12.3.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/cffi/cffi-1.12.3.ebuild b/dev-python/cffi/cffi-1.12.3.ebuild
deleted file mode 100644
index 297c0da19387..000000000000
--- a/dev-python/cffi/cffi-1.12.3.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# DO NOT ADD pypy to PYTHON_COMPAT
-# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Foreign Function Interface for Python calling C code"
-HOMEPAGE="https://cffi.readthedocs.io/ https://pypi.org/project/cffi/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- virtual/libffi:=
- dev-python/pycparser[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( dev-python/sphinx )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
-DISTUTILS_IN_SOURCE_BUILD=1
-
-src_configure() {
- tc-export PKG_CONFIG
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- "${PYTHON}" -c "import _cffi_backend as backend" || die
- pytest -x -vv \
- --ignore testing/test_zintegration.py \
- --ignore testing/embedding \
- c/ testing/ \
- || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
- distutils-r1_python_install_all
-}