summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cffi/files/cffi-1.14.0-darwin-no-brew.patch')
-rw-r--r--dev-python/cffi/files/cffi-1.14.0-darwin-no-brew.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-python/cffi/files/cffi-1.14.0-darwin-no-brew.patch b/dev-python/cffi/files/cffi-1.14.0-darwin-no-brew.patch
new file mode 100644
index 000000000000..c92b6112b853
--- /dev/null
+++ b/dev-python/cffi/files/cffi-1.14.0-darwin-no-brew.patch
@@ -0,0 +1,14 @@
+diff --git a/setup.py b/setup.py
+index e1dd39d..3e88f74 100644
+--- a/setup.py
++++ b/setup.py
+@@ -105,9 +105,6 @@ def uses_msvc():
+ return config.try_compile('#ifndef _MSC_VER\n#error "not MSVC"\n#endif')
+
+ def use_pkg_config():
+- if sys.platform == 'darwin' and os.path.exists('/usr/local/bin/brew'):
+- use_homebrew_for_libffi()
+-
+ _ask_pkg_config(include_dirs, '--cflags-only-I', '-I', sysroot=True)
+ _ask_pkg_config(extra_compile_args, '--cflags-only-other')
+ _ask_pkg_config(library_dirs, '--libs-only-L', '-L', sysroot=True)