summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/construct/construct-2.8.17.ebuild')
-rw-r--r--dev-python/construct/construct-2.8.17.ebuild27
1 files changed, 0 insertions, 27 deletions
diff --git a/dev-python/construct/construct-2.8.17.ebuild b/dev-python/construct/construct-2.8.17.ebuild
deleted file mode 100644
index 4235c921ade4..000000000000
--- a/dev-python/construct/construct-2.8.17.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="A powerful declarative parser for binary data"
-HOMEPAGE="http://construct.readthedocs.io/ https://pypi.org/project/construct/"
-SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND="test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/tox[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- py.test -vv || die "Tests failed under ${EPYTHON}"
-}