summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsondiff/jsondiff-2.0.0-r1.ebuild')
-rw-r--r--dev-python/jsondiff/jsondiff-2.0.0-r1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/jsondiff/jsondiff-2.0.0-r1.ebuild b/dev-python/jsondiff/jsondiff-2.0.0-r1.ebuild
deleted file mode 100644
index cadb65795ab0..000000000000
--- a/dev-python/jsondiff/jsondiff-2.0.0-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="Diff JSON and JSON-like structures in Python"
-HOMEPAGE="
- https://github.com/xlwings/jsondiff/
- https://pypi.org/project/jsondiff/
-"
-SRC_URI="
- https://github.com/xlwings/${PN}/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
- https://dev.gentoo.org/~andrewammerlaan/${P}-nose2pytest.diff
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
-
-PATCHES=(
- # https://github.com/xlwings/jsondiff/pull/51
- "${DISTDIR}/${P}-nose2pytest.diff"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Avoid file collision with jsonpatch's jsondiff cli.
- sed -e "/'jsondiff=jsondiff.cli/ d" -i setup.py || die
- distutils-r1_python_prepare_all
-}