summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/meson-python')
-rw-r--r--dev-python/meson-python/meson-python-0.13.1.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-python/meson-python/meson-python-0.13.1.ebuild b/dev-python/meson-python/meson-python-0.13.1.ebuild
index 5da2413af08a..d8d66b145d32 100644
--- a/dev-python/meson-python/meson-python-0.13.1.ebuild
+++ b/dev-python/meson-python/meson-python-0.13.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1
@@ -52,6 +52,17 @@ python_test() {
)
unset NINJA
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ EPYTEST_DESELECT+=(
+ # broken venv usage that copies pypy3 executable, making it
+ # unable to find lib_pypy
+ tests/test_editable.py::test_editable_install
+ tests/test_editable.py::test_editble_reentrant
+ tests/test_examples.py::test_spam
+ tests/test_wheel.py::test_local_lib
+ )
+ fi
+
epytest
rm -rf docs/examples/spam/build/ || die # remove artifacts