summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/mypy-1.13.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/mypy/mypy-1.13.0.ebuild b/dev-python/mypy/mypy-1.13.0.ebuild
index efcb38ff536c..11cd237cb444 100644
--- a/dev-python/mypy/mypy-1.13.0.ebuild
+++ b/dev-python/mypy/mypy-1.13.0.ebuild
@@ -56,6 +56,13 @@ distutils_enable_tests pytest
# test files (https://github.com/mypyc/mypyc/issues/1014)
export CCACHE_DISABLE=1
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # don't force pytest-xdist, in case user asked for EPYTEST_JOBS=1
+ sed -i -e '/addopts/s:-nauto::' pyproject.toml || die
+}
+
python_compile() {
local -x MYPY_USE_MYPYC=$(usex native-extensions 1 0)
case ${EPYTHON} in