summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nagiosplugin/nagiosplugin-1.2.3.ebuild')
-rw-r--r--dev-python/nagiosplugin/nagiosplugin-1.2.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/nagiosplugin/nagiosplugin-1.2.3.ebuild b/dev-python/nagiosplugin/nagiosplugin-1.2.3.ebuild
new file mode 100644
index 000000000000..9359a4076a4d
--- /dev/null
+++ b/dev-python/nagiosplugin/nagiosplugin-1.2.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A class library for writing nagios-compatible plugins"
+HOMEPAGE="https://bitbucket.org/flyingcircus/nagiosplugin/ https://pypi.python.org/pypi/nagiosplugin/"
+if [[ ${PV} == "9999" ]] ; then
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/flyingcircus/nagiosplugin/"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ZPL"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"