summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-afl/python-afl-0.6.ebuild')
-rw-r--r--dev-python/python-afl/python-afl-0.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-afl/python-afl-0.6.ebuild b/dev-python/python-afl/python-afl-0.6.ebuild
new file mode 100644
index 000000000000..cb3375a8e445
--- /dev/null
+++ b/dev-python/python-afl/python-afl-0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Enables American fuzzy lop fork server and instrumentation for pure-Python code"
+HOMEPAGE="https://github.com/jwilk/python-afl http://jwilk.net/software/python-afl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="app-forensics/afl"
+DEPEND=">=dev-python/cython-0.19[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # afl-cmin errors with: "Error: do not use this script in /tmp or /var/tmp"
+ rm tests/test_cmin.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PATH="${PATH}:." nosetests --verbose || die
+}