summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pythondialog/pythondialog-3.3.0-r200.ebuild')
-rw-r--r--dev-python/pythondialog/pythondialog-3.3.0-r200.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/pythondialog/pythondialog-3.3.0-r200.ebuild b/dev-python/pythondialog/pythondialog-3.3.0-r200.ebuild
deleted file mode 100644
index 78b66f086094..000000000000
--- a/dev-python/pythondialog/pythondialog-3.3.0-r200.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python module for making simple text/console-mode user interfaces"
-HOMEPAGE="http://pythondialog.sourceforge.net/ https://pypi.org/project/python2-pythondialog/"
-SRC_URI="mirror://pypi/${PN:0:1}/python2-${PN}/python2-${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="python-2"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
-IUSE="doc examples"
-
-RDEPEND="dev-util/dialog"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/python2-${P}
-
-python_prepare_all() {
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- use doc && local HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
-}