summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/unittest2/unittest2-1.1.0-r1.ebuild')
-rw-r--r--dev-python/unittest2/unittest2-1.1.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/unittest2/unittest2-1.1.0-r1.ebuild b/dev-python/unittest2/unittest2-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..d26b3441a6bd
--- /dev/null
+++ b/dev-python/unittest2/unittest2-1.1.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The new features in unittest backported to Python 2.4+"
+HOMEPAGE="https://pypi.org/project/unittest2/ https://github.com/testing-cabal/unittest-ext"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ dev-python/linecache2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
+ dev-python/traceback2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+PATCHES=(
+ "${FILESDIR}"/remove-argparse-dependence.patch
+ "${FILESDIR}"/${P}-python3.5-test.patch
+)
+
+python_test() {
+ "${PYTHON}" -m unittest2 discover --verbose ||
+ die "tests failed under ${EPYTHON}"
+}