summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/hashicorp-checkpoint/hashicorp-checkpoint-0.1.5-r1.ebuild')
-rw-r--r--dev-ruby/hashicorp-checkpoint/hashicorp-checkpoint-0.1.5-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/hashicorp-checkpoint/hashicorp-checkpoint-0.1.5-r1.ebuild b/dev-ruby/hashicorp-checkpoint/hashicorp-checkpoint-0.1.5-r1.ebuild
new file mode 100644
index 000000000000..a1319f71705b
--- /dev/null
+++ b/dev-ruby/hashicorp-checkpoint/hashicorp-checkpoint-0.1.5-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="ruby-checkpoint.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Internal HashiCorp service to check version information"
+HOMEPAGE="https://www.hashicorp.com"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/rspec-its )
+"
+
+all_ruby_prepare() {
+ # remove bundler support
+ sed -i '/[Bb]undler/d' Rakefile || die
+}