summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/path_expander/path_expander-1.0.1.ebuild')
-rw-r--r--dev-ruby/path_expander/path_expander-1.0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/path_expander/path_expander-1.0.1.ebuild b/dev-ruby/path_expander/path_expander-1.0.1.ebuild
new file mode 100644
index 000000000000..8b1bec6db61d
--- /dev/null
+++ b/dev-ruby/path_expander/path_expander-1.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Helps pre-process command-line arguments expanding directories into their constituent files."
+HOMEPAGE="https://github.com/seattlerb/path_expander"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="1"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}