summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gengetopt/gengetopt-2.22.6.ebuild')
-rw-r--r--dev-util/gengetopt/gengetopt-2.22.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/gengetopt/gengetopt-2.22.6.ebuild b/dev-util/gengetopt/gengetopt-2.22.6.ebuild
new file mode 100644
index 000000000000..5a29f7f8a3c9
--- /dev/null
+++ b/dev-util/gengetopt/gengetopt-2.22.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="A tool to write command line option parsing code for C programs"
+HOMEPAGE="http://www.gnu.org/software/gengetopt/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-no-docs.patch
+ epatch "${FILESDIR}"/${P}-docdirs.patch
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+ docompress -x /usr/share/doc/${PF}/examples
+}