summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/garden/files')
-rw-r--r--games-action/garden/files/garden-1.0.8-dash.patch33
-rw-r--r--games-action/garden/files/garden-1.0.8-drop-AS_INIT.patch19
-rw-r--r--games-action/garden/files/garden-1.0.8-underlink.patch19
-rw-r--r--games-action/garden/files/garden-1.0.9-dash.patch33
-rw-r--r--games-action/garden/files/garden-1.0.9-resources.patch7
5 files changed, 111 insertions, 0 deletions
diff --git a/games-action/garden/files/garden-1.0.8-dash.patch b/games-action/garden/files/garden-1.0.8-dash.patch
new file mode 100644
index 000000000000..2d8630236ffb
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.8-dash.patch
@@ -0,0 +1,33 @@
+--- configure.ac.orig 2015-05-04 14:48:03.467935640 -0400
++++ configure.ac 2015-05-04 14:48:24.729199607 -0400
+@@ -80,7 +80,7 @@
+ [have_allegro="no"])
+ AC_MSG_RESULT([$have_allegro])
+ LIBS=$LIBS_SAVE
+- AS_IF([test "x$have_allegro" == "xyes"],
++ AS_IF([test "x$have_allegro" = "xyes"],
+ [return 0],
+ [return 1])
+ }
+@@ -89,7 +89,7 @@
+ AM_PATH_ALLEGRO([4.2.0])
+
+ try_link_allegro "$allegro_LIBS"
+-AS_IF([test "x$?" == "x0"],
++AS_IF([test "x$?" = "x0"],
+ [[LIBS="$LIBS $allegro_LIBS"
+ ALLEGRO_LIB=`echo $allegro_LIBS | sed -e 's/-l\([^[:blank:]]*\).*/\1/'`
+ have_allegro="yes"]])
+@@ -103,10 +103,10 @@
+ for lib in $ALLEGRO_LIBS
+ do
+ ldflag="-l$lib"
+- AS_IF([test "x$have_allegro" == "xyes"],
++ AS_IF([test "x$have_allegro" = "xyes"],
+ [break])
+ try_link_allegro $ldflag
+- AS_IF([test "x$?" == "x0"],
++ AS_IF([test "x$?" = "x0"],
+ [LIBS="$LIBS $ldflag"
+ ALLEGRO_LIB="$lib"
+ have_allegro="yes"])
diff --git a/games-action/garden/files/garden-1.0.8-drop-AS_INIT.patch b/games-action/garden/files/garden-1.0.8-drop-AS_INIT.patch
new file mode 100644
index 000000000000..69cff8fa319d
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.8-drop-AS_INIT.patch
@@ -0,0 +1,19 @@
+At least for autoconf-2.69 AS_INIT is called by AC_INIT.
+
+When using /bin/dash calling AS_INIT directly leads to infinite
+reexec loop.
+
+Gentoo-bug: http://bugs.gentoo.org/475248
+diff --git a/configure.ac b/configure.ac
+index eb0002f..6c77ef9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -5,7 +5,7 @@ AC_PREREQ(2.62)
+ AC_INIT([GARDEN],
+ [1.0.8],
+ [bubla@users.sourceforge.net])
+-AS_INIT
++
+ AC_CONFIG_AUX_DIR([build-aux])
+ AM_INIT_AUTOMAKE([-Wall])
+ AC_CONFIG_SRCDIR([src/input.h])
diff --git a/games-action/garden/files/garden-1.0.8-underlink.patch b/games-action/garden/files/garden-1.0.8-underlink.patch
new file mode 100644
index 000000000000..bd25a4d57384
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.8-underlink.patch
@@ -0,0 +1,19 @@
+--- bin/Makefile.am.old 2011-06-22 18:16:30.654661047 +0200
++++ bin/Makefile.am 2011-06-22 18:16:55.662251326 +0200
+@@ -9,6 +9,7 @@
+ garden_LDFLAGS = -static
+ else #unix version :-)
+ AM_CPPFLAGS = -D'DATADIR="@DATADIR_NAME@"'
++garden_LDADD = -lm
+ endif
+
+ #how to build resources?
+--- Makefile.am.old 2011-06-22 18:19:37.787560851 +0200
++++ Makefile.am 2011-06-22 18:19:44.078960907 +0200
+@@ -1,5 +1,5 @@
+ ACLOCAL_AMFLAGS= -I m4
+-SUBDIRS = bin resources
++SUBDIRS = bin
+
+ if NO_EXISTING_DATA
+ SUBDIRS += data
diff --git a/games-action/garden/files/garden-1.0.9-dash.patch b/games-action/garden/files/garden-1.0.9-dash.patch
new file mode 100644
index 000000000000..2d8630236ffb
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.9-dash.patch
@@ -0,0 +1,33 @@
+--- configure.ac.orig 2015-05-04 14:48:03.467935640 -0400
++++ configure.ac 2015-05-04 14:48:24.729199607 -0400
+@@ -80,7 +80,7 @@
+ [have_allegro="no"])
+ AC_MSG_RESULT([$have_allegro])
+ LIBS=$LIBS_SAVE
+- AS_IF([test "x$have_allegro" == "xyes"],
++ AS_IF([test "x$have_allegro" = "xyes"],
+ [return 0],
+ [return 1])
+ }
+@@ -89,7 +89,7 @@
+ AM_PATH_ALLEGRO([4.2.0])
+
+ try_link_allegro "$allegro_LIBS"
+-AS_IF([test "x$?" == "x0"],
++AS_IF([test "x$?" = "x0"],
+ [[LIBS="$LIBS $allegro_LIBS"
+ ALLEGRO_LIB=`echo $allegro_LIBS | sed -e 's/-l\([^[:blank:]]*\).*/\1/'`
+ have_allegro="yes"]])
+@@ -103,10 +103,10 @@
+ for lib in $ALLEGRO_LIBS
+ do
+ ldflag="-l$lib"
+- AS_IF([test "x$have_allegro" == "xyes"],
++ AS_IF([test "x$have_allegro" = "xyes"],
+ [break])
+ try_link_allegro $ldflag
+- AS_IF([test "x$?" == "x0"],
++ AS_IF([test "x$?" = "x0"],
+ [LIBS="$LIBS $ldflag"
+ ALLEGRO_LIB="$lib"
+ have_allegro="yes"])
diff --git a/games-action/garden/files/garden-1.0.9-resources.patch b/games-action/garden/files/garden-1.0.9-resources.patch
new file mode 100644
index 000000000000..6acd6f5f78d5
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.9-resources.patch
@@ -0,0 +1,7 @@
+--- Makefile.am.orig 2015-05-04 16:57:07.510191036 -0400
++++ Makefile.am 2015-05-04 16:57:14.581946228 -0400
+@@ -1,3 +1,3 @@
+ ACLOCAL_AMFLAGS= -I m4
+
+-SUBDIRS = src resources data
++SUBDIRS = src data