summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/rav1e')
-rw-r--r--media-video/rav1e/rav1e-0.7.1.ebuild5
-rw-r--r--media-video/rav1e/rav1e-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/media-video/rav1e/rav1e-0.7.1.ebuild b/media-video/rav1e/rav1e-0.7.1.ebuild
index 3f21fd7d33c8..6e51df483cb6 100644
--- a/media-video/rav1e/rav1e-0.7.1.ebuild
+++ b/media-video/rav1e/rav1e-0.7.1.ebuild
@@ -265,6 +265,8 @@ BDEPEND="
amd64? ( ${ASM_DEP} )
capi? ( >=dev-util/cargo-c-0.6.3 )
"
+# only used as a build script to check the version of rav1e...
+DEPEND="dev-libs/libgit2"
# Rust
QA_FLAGS_IGNORED="usr/lib.*/librav1e.* usr/bin/rav1e"
@@ -280,6 +282,9 @@ src_unpack() {
}
src_compile() {
+ # used by build script to get rav1e repository info
+ export LIBGIT2_NO_VENDOR=1
+
cargo_src_compile
if use capi; then
diff --git a/media-video/rav1e/rav1e-9999.ebuild b/media-video/rav1e/rav1e-9999.ebuild
index 3f21fd7d33c8..6e51df483cb6 100644
--- a/media-video/rav1e/rav1e-9999.ebuild
+++ b/media-video/rav1e/rav1e-9999.ebuild
@@ -265,6 +265,8 @@ BDEPEND="
amd64? ( ${ASM_DEP} )
capi? ( >=dev-util/cargo-c-0.6.3 )
"
+# only used as a build script to check the version of rav1e...
+DEPEND="dev-libs/libgit2"
# Rust
QA_FLAGS_IGNORED="usr/lib.*/librav1e.* usr/bin/rav1e"
@@ -280,6 +282,9 @@ src_unpack() {
}
src_compile() {
+ # used by build script to get rav1e repository info
+ export LIBGIT2_NO_VENDOR=1
+
cargo_src_compile
if use capi; then