summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/vcsi/vcsi-7.ebuild')
-rw-r--r--media-video/vcsi/vcsi-7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-video/vcsi/vcsi-7.ebuild b/media-video/vcsi/vcsi-7.ebuild
new file mode 100644
index 000000000000..87cb0c19609a
--- /dev/null
+++ b/media-video/vcsi/vcsi-7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create thumbnail sheets from video files"
+HOMEPAGE="https://github.com/amietn/vcsi"
+SRC_URI="https://github.com/amietn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ >=dev-python/jinja-2[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ dev-python/parsedatetime[${PYTHON_USEDEP}]
+ >=dev-python/texttable-1.0[${PYTHON_USEDEP}]
+ media-fonts/dejavu
+ media-video/ffmpeg
+"
+
+python_test() {
+ nosetests -v tests || die "python tests failed with nose"
+}