summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libsoup/libsoup-2.99.9.ebuild')
-rw-r--r--net-libs/libsoup/libsoup-2.99.9.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/net-libs/libsoup/libsoup-2.99.9.ebuild b/net-libs/libsoup/libsoup-2.99.9.ebuild
index be126cebc636..9c73bf6e9873 100644
--- a/net-libs/libsoup/libsoup-2.99.9.ebuild
+++ b/net-libs/libsoup/libsoup-2.99.9.ebuild
@@ -42,6 +42,7 @@ BDEPEND="
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
vala? ( $(vala_depend) )
+ test? ( net-libs/gnutls[pkcs11] )
"
# test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
# apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
@@ -82,13 +83,11 @@ multilib_src_configure() {
$(meson_native_use_feature introspection)
$(meson_native_use_feature vala vapi)
$(meson_native_use_bool gtk-doc gtk_doc)
+ # TODO: Tests fail with network-sandbox or 32bit (upstream issue #236) for 2.99.9
$(meson_use test tests)
-Dinstalled_tests=false
$(meson_feature sysprof)
- # Avoid gnutls[pkcs11] test dep for now, consider adding them back or fixing
- # upstream to skip them when pkcs11 API isn't there (in 2.99.9 it automatically
- # skips these only if gnutls overall is missing)
- -Dpkcs11_tests=disabled
+ $(meson_feature test pkcs11_tests)
)
meson_src_configure
}