summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/phodav')
-rw-r--r--net-libs/phodav/Manifest1
-rw-r--r--net-libs/phodav/phodav-3.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-libs/phodav/Manifest b/net-libs/phodav/Manifest
index 01dc91841c08..5e00c15a67b2 100644
--- a/net-libs/phodav/Manifest
+++ b/net-libs/phodav/Manifest
@@ -1 +1,2 @@
DIST phodav-2.5.tar.xz 62992 BLAKE2B aca0141c20c727dd27af3760caf27ec0f7a4936c3c35dbdb60a8a15b5bd75ebd97dfef8bb96f50b266d7a0e53fb8c0e21416dea855ff107b362dba0e89283a64 SHA512 4b6cd6a40118bf9c042abcfc3e7cb593b620922aae4dd3daf77682bf9da2030a0958bc0206531d5950f85551ef8f5da21fb21c54b9bd5e56b880f54e0983bc01
+DIST phodav-3.0.tar.xz 65728 BLAKE2B c7980fc9c8e5fe3034b16bbb6433d09b4365a5c50188476f4dfcb1d1ae32f4988c22933b4c811dbef44fe5fc4fbebcf6beb8e859a3c9d01fb7075336caaba8ca SHA512 a4720083fd581023ea78cc09e6df4b5d2f90894f916004cf28c7fa557da61d8c7a5539fa6b50647efcd9f771afd088889fdc40579a8e860c8ea20540b25eb26a
diff --git a/net-libs/phodav/phodav-3.0.ebuild b/net-libs/phodav/phodav-3.0.ebuild
new file mode 100644
index 000000000000..417b8f4b9adf
--- /dev/null
+++ b/net-libs/phodav/phodav-3.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson systemd udev
+
+DESCRIPTION="WebDav server implementation using libsoup"
+HOMEPAGE="https://wiki.gnome.org/phodav https://gitlab.gnome.org/GNOME/phodav"
+
+LICENSE="LGPL-2.1+"
+SLOT="3.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="gtk-doc systemd test zeroconf"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.51.2:2
+ >=net-libs/libsoup-3.0.0:3.0
+ dev-libs/libxml2
+ zeroconf? ( net-dns/avahi[dbus] )
+
+ !net-libs/phodav:2.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/asciidoc
+ app-text/docbook-xml-dtd:4.5
+ app-text/xmlto
+ sys-devel/gettext
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )
+ test? ( gnome-base/dconf )
+"
+
+src_prepare() {
+ default
+
+ if ! use zeroconf ; then
+ sed -i -e 's|avahi-daemon.service||' data/spice-webdavd.service || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature gtk-doc gtk_doc)
+ $(meson_feature zeroconf avahi)
+ -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
+ -Dudevrulesdir="$(get_udevdir)/rules.d"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if ! use systemd ; then
+ newinitd "${FILESDIR}/spice-webdavd.initd" spice-webdavd
+ udev_dorules "${FILESDIR}/70-spice-webdavd.rules"
+ fi
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}