summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild')
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild
index 51b698f90753..d68a3de38e5b 100644
--- a/net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild
+++ b/net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild
@@ -16,3 +16,10 @@ IUSE="test"
DEPEND=""
RDEPEND="${DEPEND}"
+
+# Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
+# Because of this we cannot use cmake-multilib_src_configure() here.
+multilib_src_configure() {
+ local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
+ cmake-utils_src_configure
+}