summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/netkit-rwho')
-rw-r--r--net-misc/netkit-rwho/Manifest2
-rw-r--r--net-misc/netkit-rwho/files/netkit-rwho-0.17-confd4
-rw-r--r--net-misc/netkit-rwho/files/netkit-rwho-0.17-cron8
-rw-r--r--net-misc/netkit-rwho/files/netkit-rwho-0.17-printf.patch23
-rw-r--r--net-misc/netkit-rwho/files/netkit-rwho-0.17-rc17
-rw-r--r--net-misc/netkit-rwho/metadata.xml5
-rw-r--r--net-misc/netkit-rwho/netkit-rwho-0.17-r4.ebuild48
7 files changed, 107 insertions, 0 deletions
diff --git a/net-misc/netkit-rwho/Manifest b/net-misc/netkit-rwho/Manifest
new file mode 100644
index 000000000000..1802cc70b712
--- /dev/null
+++ b/net-misc/netkit-rwho/Manifest
@@ -0,0 +1,2 @@
+DIST netkit-rwho-0.17-patches.tar.bz2 7725 SHA256 c666d60fa21538f909374cdc1a3e661875559c3859f759fe060f35047dc3e54e SHA512 947f62316220791af7f36eee3d44481224ebda3410fb3e527fb1f066a663f56d6aec44483955edbbff1936972e86aeff9d6905d123ed78cb10d72ee6cb0f7454 WHIRLPOOL 5b8c47050a44ee3a80b6b622da9b947e30176d535cce2682a160df3c46153a321d279a30386df4aa21c69bdb12ecbaf20e0fa5867648e96917697f3ede394842
+DIST netkit-rwho-0.17.tar.gz 20610 SHA256 0409e2ce4bfdb2dacb2c193d0fedfc49bb975cb057c5c6b0ffcca603a1188da7 SHA512 ea1444b613d95f53100cf8f8d374dd132611432380b9142182c4fb5595014605896656b9a272945534371265e226fe591c22c12a9bdde9c763794249660e7b58 WHIRLPOOL 65a7d4851cba7c94d240e56e254df4978741eb780dd269063773620289894cc7269e5491e5955c22746345f4e4191379d10a022a1317a091a1e3a13210de1418
diff --git a/net-misc/netkit-rwho/files/netkit-rwho-0.17-confd b/net-misc/netkit-rwho/files/netkit-rwho-0.17-confd
new file mode 100644
index 000000000000..3a5f684f1544
--- /dev/null
+++ b/net-misc/netkit-rwho/files/netkit-rwho-0.17-confd
@@ -0,0 +1,4 @@
+# /etc/conf.d/rwhod: config file for /etc/init.d/rwhod
+
+# rwhod arguments
+RWHOD_OPTIONS="-b"
diff --git a/net-misc/netkit-rwho/files/netkit-rwho-0.17-cron b/net-misc/netkit-rwho/files/netkit-rwho-0.17-cron
new file mode 100644
index 000000000000..96c6ddf6d2f1
--- /dev/null
+++ b/net-misc/netkit-rwho/files/netkit-rwho-0.17-cron
@@ -0,0 +1,8 @@
+#!/bin/sh
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+#
+# Clean up stale rwho entries after one month
+find /var/spool/rwho -mindepth 1 -maxdepth 1 -type f ! -name .keep \
+ ! -ctime -30 -print0 | xargs -r0 rm -f
diff --git a/net-misc/netkit-rwho/files/netkit-rwho-0.17-printf.patch b/net-misc/netkit-rwho/files/netkit-rwho-0.17-printf.patch
new file mode 100644
index 000000000000..89eaf82881f8
--- /dev/null
+++ b/net-misc/netkit-rwho/files/netkit-rwho-0.17-printf.patch
@@ -0,0 +1,23 @@
+echo -n isn't supported by all shells, use printf instead, which is portable.
+
+Note, if you apply this patch after 0004-ldflags.patch, the changes begin at line 276.
+If you run it before 0004-ldflags.patch, the changes begin at line 277.
+
+Patch by Andrew Miller.
+
+https://bugs.gentoo.org/529974
+
+--- a/configure
++++ b/configure
+@@ -276,10 +276,7 @@
+
+ echo 'Generating MCONFIG...'
+ (
+- echo -n '# Generated by configure (confgen version 2) on '
+- date
+- echo '#'
+- echo
++ printf "#\n# Generated by configure (confgen version 2) on $(date)\n#\n\n"
+
+ echo "BINDIR=$BINDIR"
+ echo "SBINDIR=$SBINDIR"
diff --git a/net-misc/netkit-rwho/files/netkit-rwho-0.17-rc b/net-misc/netkit-rwho/files/netkit-rwho-0.17-rc
new file mode 100644
index 000000000000..480adc98e8b1
--- /dev/null
+++ b/net-misc/netkit-rwho/files/netkit-rwho-0.17-rc
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting rwhod"
+ /sbin/start-stop-daemon --start --quiet --exec /usr/sbin/rwhod -- $RWHOD_OPTIONS
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping rwhod"
+ /sbin/start-stop-daemon --stop --quiet --name rwhod
+ eend $?
+}
diff --git a/net-misc/netkit-rwho/metadata.xml b/net-misc/netkit-rwho/metadata.xml
new file mode 100644
index 000000000000..43ff75467369
--- /dev/null
+++ b/net-misc/netkit-rwho/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-misc/netkit-rwho/netkit-rwho-0.17-r4.ebuild b/net-misc/netkit-rwho/netkit-rwho-0.17-r4.ebuild
new file mode 100644
index 000000000000..a06307396f48
--- /dev/null
+++ b/net-misc/netkit-rwho/netkit-rwho-0.17-r4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Netkit - ruptime/rwho/rwhod"
+HOMEPAGE="http://www.hcs.harvard.edu/~dholland/computers/netkit.html"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz
+ https://dev.gentoo.org/~jer/${P}-patches.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~mips ppc s390 sh sparc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${WORKDIR}"/000{1,2,3,4}-*.patch
+ epatch "${FILESDIR}"/${P}-printf.patch #529974
+}
+
+src_configure() {
+ # Not an autotools build system
+ ./configure --with-c-compiler=$(tc-getCC) || die
+ sed -i \
+ -e "s:-O2::" \
+ -e "s:-Wpointer-arith::" \
+ MCONFIG || die
+}
+
+src_install() {
+ keepdir /var/spool/rwho
+
+ into /usr
+ dobin ruptime/ruptime rwho/rwho
+ dosbin rwhod/rwhod
+
+ doman ruptime/ruptime.1 rwho/rwho.1 rwhod/rwhod.8
+ dodoc README ChangeLog
+
+ newinitd "${FILESDIR}"/${P}-rc rwhod
+ newconfd "${FILESDIR}"/${P}-confd rwhod
+
+ exeinto /etc/cron.monthly
+ doexe "${FILESDIR}"/${P}-cron
+}