summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/airdcpp-webclient/airdcpp-webclient-0.16.5.ebuild')
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-0.16.5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-0.16.5.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-0.16.5.ebuild
new file mode 100644
index 000000000000..e7ca695037a4
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-0.16.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://github.com/airdcpp-web/airdcpp-webclient"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+webui"
+
+RDEPEND="
+ dev-libs/geoip
+ app-arch/bzip2
+ sys-libs/zlib
+ dev-libs/openssl:0
+ dev-cpp/tbb
+ virtual/libiconv
+ net-libs/miniupnpc
+ dev-libs/leveldb
+ dev-cpp/websocketpp
+ dev-libs/boost
+"
+DEPEND="
+ net-libs/nodejs
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}