summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/grass/grass-9999.ebuild')
-rw-r--r--sci-geosciences/grass/grass-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sci-geosciences/grass/grass-9999.ebuild b/sci-geosciences/grass/grass-9999.ebuild
index 1c0613f94251..0844f7c7bbff 100644
--- a/sci-geosciences/grass/grass-9999.ebuild
+++ b/sci-geosciences/grass/grass-9999.ebuild
@@ -36,7 +36,7 @@ else
S="${WORKDIR}/${MY_P}"
fi
-IUSE="blas bzip2 cxx fftw geos lapack las mysql netcdf nls odbc opencl opengl openmp pdal png postgres readline sqlite threads tiff truetype X zstd"
+IUSE="blas bzip2 cxx fftw geos lapack las mysql netcdf nls odbc opencl opengl openmp pdal png postgres readline sqlite svm threads tiff truetype X zstd"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
opengl? ( X )"
@@ -48,7 +48,6 @@ RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/ply[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
')
sci-libs/gdal:=
sys-libs/gdbm:=
@@ -76,6 +75,7 @@ RDEPEND="
postgres? ( >=dev-db/postgresql-8.4:= )
readline? ( sys-libs/readline:= )
sqlite? ( dev-db/sqlite:3 )
+ svm? ( sci-libs/libsvm:= )
tiff? ( media-libs/tiff:= )
truetype? ( media-libs/freetype:2 )
X? (
@@ -202,6 +202,7 @@ src_configure() {
$(use_with las liblas "${EPREFIX}"/usr/bin/liblas-config)
$(use_with netcdf netcdf "${EPREFIX}"/usr/bin/nc-config)
$(use_with geos geos "${EPREFIX}"/usr/bin/geos-config)
+ $(use_with svm libsvm)
$(use_with X x)
$(use_with zstd)
)