summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/cpuid/files/cpuid-20150606-Makefile.patch')
-rw-r--r--sys-apps/cpuid/files/cpuid-20150606-Makefile.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-apps/cpuid/files/cpuid-20150606-Makefile.patch b/sys-apps/cpuid/files/cpuid-20150606-Makefile.patch
new file mode 100644
index 000000000000..f878977ece91
--- /dev/null
+++ b/sys-apps/cpuid/files/cpuid-20150606-Makefile.patch
@@ -0,0 +1,21 @@
+--- cpuid-20150606/Makefile
++++ cpuid-20150606/Makefile
+@@ -1,9 +1,3 @@
+-CFLAGS+=-g
+-CPPFLAGS?=
+-LDFLAGS?=
+-ifneq (,$(findstring arch=i386,$(CFLAGS)))
+-CISA=-m32
+-endif
+ CFL=$(CPPFLAGS) $(CFLAGS) $(CISA) -Wall -Wshadow -Wcast-align -Wredundant-decls -Wbad-function-cast -Wcast-qual -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -D_FILE_OFFSET_BITS=64 -DVERSION=$(VERSION)
+
+ PACKAGE=cpuid
+@@ -44,7 +38,7 @@
+ gzip < $< > $@
+
+ install: $(PROG) $(PROG).man.gz
+- install -D -s -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
++ install -D -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
+ install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
+
+ clean: