summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ed/ed-1.10.ebuild')
-rw-r--r--sys-apps/ed/ed-1.10.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/ed/ed-1.10.ebuild b/sys-apps/ed/ed-1.10.ebuild
new file mode 100644
index 000000000000..241de6ff4df7
--- /dev/null
+++ b/sys-apps/ed/ed-1.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs unpacker
+
+DESCRIPTION="Your basic line editor"
+HOMEPAGE="http://www.gnu.org/software/ed/"
+SRC_URI="mirror://gnu/ed/${P}.tar.lz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="$(unpacker_src_uri_depends)
+ sys-apps/texinfo"
+RDEPEND=""
+
+src_configure() {
+ # Upstream configure script is moronic.
+ econf \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${CFLAGS} ${LDFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ --bindir="${EPREFIX}/bin"
+}