summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ucspi-proxy/ucspi-proxy-0.98.ebuild')
-rw-r--r--sys-apps/ucspi-proxy/ucspi-proxy-0.98.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/ucspi-proxy/ucspi-proxy-0.98.ebuild b/sys-apps/ucspi-proxy/ucspi-proxy-0.98.ebuild
new file mode 100644
index 000000000000..294ee53df0ec
--- /dev/null
+++ b/sys-apps/ucspi-proxy/ucspi-proxy-0.98.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="proxy program for two connections set up by a UCSPI server and a UCSPI client"
+HOMEPAGE="http://untroubled.org/ucspi-proxy/"
+SRC_URI="http://untroubled.org/ucspi-proxy/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/bglibs-1.106"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e '/^>bin$/ac:::755::ucspi-proxy' INSTHIER
+}
+
+src_configure() {
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ echo "${D}/usr/bin" > conf-bin
+ echo "${D}/usr/share/man" > conf-man
+ echo "/usr/include/bglibs" > conf-bgincs
+ echo "/usr/$(get_libdir)/bglibs" > conf-bglibs
+}
+
+src_install() {
+ einstall || die
+ dodoc ANNOUNCEMENT NEWS README TODO
+}