summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ceph-14.2.9.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/sys-cluster/ceph/ceph-14.2.9.ebuild b/sys-cluster/ceph/ceph-14.2.9.ebuild
index 95abd364b0f5..75b01167a716 100644
--- a/sys-cluster/ceph/ceph-14.2.9.ebuild
+++ b/sys-cluster/ceph/ceph-14.2.9.ebuild
@@ -197,12 +197,10 @@ src_prepare() {
cmake-utils_src_prepare
if use system-boost; then
- eapply "${FILESDIR}/ceph-14.2.8-boost-sonames.patch"
-
find "${S}" -name '*.cmake' -or -name 'CMakeLists.txt' -print0 \
| xargs --null sed \
- -e 's|Boost::|Boost_|g' \
- -e 's|Boost_boost|boost_system|g' -i || die
+ -e 's|Boost::|boost_|g' \
+ -e 's|boost_boost|boost_system|g' -i || die
fi
sed -i -r "s:DESTINATION .+\\):DESTINATION $(get_bashcompdir)\\):" \