summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/chromium/chromium-45.0.2454.101.ebuild')
-rw-r--r--www-client/chromium/chromium-45.0.2454.101.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/www-client/chromium/chromium-45.0.2454.101.ebuild b/www-client/chromium/chromium-45.0.2454.101.ebuild
index 15fbe60035bc..c450cda3ef16 100644
--- a/www-client/chromium/chromium-45.0.2454.101.ebuild
+++ b/www-client/chromium/chromium-45.0.2454.101.ebuild
@@ -469,17 +469,19 @@ src_configure() {
fi
# Make sure the build system will use the right tools, bug #340795.
- tc-export AR CC CXX RANLIB
+ tc-export AR CC CXX NM
# Tools for building programs to be executed on the build system, bug #410883.
- export AR_host=$(tc-getBUILD_AR)
- export CC_host=$(tc-getBUILD_CC)
- export CXX_host=$(tc-getBUILD_CXX)
- export LD_host=${CXX_host}
+ if tc-is-cross-compiler; then
+ export AR_host=$(tc-getBUILD_AR)
+ export CC_host=$(tc-getBUILD_CC)
+ export CXX_host=$(tc-getBUILD_CXX)
+ export NM_host=$(tc-getBUILD_NM)
+ fi
# Bug 491582.
export TMPDIR="${WORKDIR}/temp"
- mkdir -m 755 "${TMPDIR}" || die
+ mkdir -p -m 755 "${TMPDIR}" || die
local build_ffmpeg_args=""
if use pic && [[ "${ffmpeg_target_arch}" == "ia32" ]]; then