summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-input-libinput/xf86-input-libinput-1.2.0.ebuild')
-rw-r--r--x11-drivers/xf86-input-libinput/xf86-input-libinput-1.2.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.2.0.ebuild b/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.2.0.ebuild
new file mode 100644
index 000000000000..4af16d07326c
--- /dev/null
+++ b/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info xorg-3
+
+DESCRIPTION="X.org input driver based on libinput"
+
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND=">=dev-libs/libinput-1.11.0:0="
+DEPEND="${RDEPEND}
+ >=x11-base/xorg-proto-2021.5"
+
+DOCS=( "README.md" )
+
+pkg_pretend() {
+ CONFIG_CHECK="~TIMERFD"
+ check_extra_config
+}