summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-composite-editor/xfce4-composite-editor-0.ebuild')
-rw-r--r--xfce-extra/xfce4-composite-editor/xfce4-composite-editor-0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-composite-editor/xfce4-composite-editor-0.ebuild b/xfce-extra/xfce4-composite-editor/xfce4-composite-editor-0.ebuild
new file mode 100644
index 000000000000..1aff29ff14b5
--- /dev/null
+++ b/xfce-extra/xfce4-composite-editor/xfce4-composite-editor-0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+MY_PN=Xfce4-Composite-Editor
+
+DESCRIPTION="An graphical interface to modify composite settings"
+HOMEPAGE="http://keithhedger.hostingsiteforfree.com/pages/apps.html#xfcecomp"
+SRC_URI="http://keithhedger.hostingsiteforfree.com/zips/${MY_PN}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND="app-shells/bash
+ >=x11-misc/gtkdialog-0.8"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-validate.patch )
+}
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ dobin xfce4-composite-editor
+ domenu xfcecomped.desktop
+ dodoc README
+}