summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-11-19 10:20:01 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-11-19 10:20:01 +0000
commit025bbd81749699a3d10bb255ea40c57012d9ac13 (patch)
treecb84873e31e231514ca7ec33c9ce218d3ad20d03
parentStable on amd64 wrt bug #390905 (diff)
downloadhistorical-025bbd81749699a3d10bb255ea40c57012d9ac13.tar.gz
historical-025bbd81749699a3d10bb255ea40c57012d9ac13.tar.bz2
historical-025bbd81749699a3d10bb255ea40c57012d9ac13.zip
Fix bugs #390845 and #386127
Package-Manager: portage-2.2.0_alpha76/cvs/Linux x86_64
-rw-r--r--net-wireless/wimax-tools/ChangeLog7
-rw-r--r--net-wireless/wimax-tools/wimax-tools-1.4.5-r1.ebuild30
-rw-r--r--net-wireless/wimax/ChangeLog7
-rw-r--r--net-wireless/wimax/wimax-1.5.2-r1.ebuild42
4 files changed, 84 insertions, 2 deletions
diff --git a/net-wireless/wimax-tools/ChangeLog b/net-wireless/wimax-tools/ChangeLog
index 1cab4c9aff91..396655c0fafb 100644
--- a/net-wireless/wimax-tools/ChangeLog
+++ b/net-wireless/wimax-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/wimax-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wimax-tools/ChangeLog,v 1.8 2011/10/27 03:45:25 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wimax-tools/ChangeLog,v 1.9 2011/11/19 10:20:01 alexxy Exp $
+
+*wimax-tools-1.4.5-r1 (19 Nov 2011)
+
+ 19 Nov 2011; Alexey Shvetsov <alexxy@gentoo.org> +wimax-tools-1.4.5-r1.ebuild:
+ Fix bugs #390845 and #386127
27 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
wimax-tools-1.4.5.ebuild:
diff --git a/net-wireless/wimax-tools/wimax-tools-1.4.5-r1.ebuild b/net-wireless/wimax-tools/wimax-tools-1.4.5-r1.ebuild
new file mode 100644
index 000000000000..4b857fb731fb
--- /dev/null
+++ b/net-wireless/wimax-tools/wimax-tools-1.4.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wimax-tools/wimax-tools-1.4.5-r1.ebuild,v 1.1 2011/11/19 10:20:01 alexxy Exp $
+
+EAPI=4
+
+inherit base linux-info multilib
+
+DESCRIPTION="Tools to use Intel's WiMax cards"
+HOMEPAGE="http://www.linuxwimax.org"
+SRC_URI="http://linuxwimax.org/Download?action=AttachFile&do=get&target=${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sys-kernel/linux-headers-2.6.34
+ >=dev-libs/libnl-1.0:1.1"
+RDEPEND=""
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.*a' -exec rm {} +
+}
diff --git a/net-wireless/wimax/ChangeLog b/net-wireless/wimax/ChangeLog
index 2480383da15a..9433ac8d8a25 100644
--- a/net-wireless/wimax/ChangeLog
+++ b/net-wireless/wimax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/wimax
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wimax/ChangeLog,v 1.11 2011/10/27 03:56:19 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wimax/ChangeLog,v 1.12 2011/11/19 10:17:13 alexxy Exp $
+
+*wimax-1.5.2-r1 (19 Nov 2011)
+
+ 19 Nov 2011; Alexey Shvetsov <alexxy@gentoo.org> +wimax-1.5.2-r1.ebuild:
+ Fix bugs #390845 and #386127
27 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org> wimax-1.5.2.ebuild:
Depend on same slot of libnl as wimax-tools.
diff --git a/net-wireless/wimax/wimax-1.5.2-r1.ebuild b/net-wireless/wimax/wimax-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..fc5e43bccd29
--- /dev/null
+++ b/net-wireless/wimax/wimax-1.5.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wimax/wimax-1.5.2-r1.ebuild,v 1.1 2011/11/19 10:17:13 alexxy Exp $
+
+EAPI="4"
+
+inherit base linux-info multilib
+
+DESCRIPTION="Intel WiMAX daemon used to interface to the hardware"
+HOMEPAGE="http://www.linuxwimax.org/"
+SRC_URI="http://www.linuxwimax.org/Download?action=AttachFile&do=get&target=${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND=">=dev-libs/libnl-1.1:1.1
+ >=sys-kernel/linux-headers-2.6.34"
+RDEPEND="${DEPEND}
+ net-wireless/wimax-tools
+ net-wireless/wpa_supplicant[wimax]"
+
+src_configure() {
+ econf \
+ --with-libwimaxll=/usr/$(get_libdir) \
+ --localstatedir=/var \
+ --with-i2400m=/usr || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ doinitd "${FILESDIR}"/wimax || die "failed to place the init daemon"
+ sed -e "s:/usr/lib/libeap.so.0:/usr/$(get_libdir)/libeap.so.0:g" \
+ -e "s:<GetDeviceTraces>3</GetDeviceTraces>:<GetDeviceTraces>0</GetDeviceTraces>:g" \
+ -e "s:<OutputTarget>console</OutputTarget>:<OutputTarget>daemon</OutputTarget>:g" \
+ -e "s:<IPRenew>1</IPRenew>:<IPRenew>0</IPRenew>:g" \
+ -i "${D}/etc/wimax/config.xml" || die "Fixing config failed"
+ # Drop udev rusles for now
+ rm -rf "${D}/etc/udev"
+ use static-libs || find "${D}" -name '*.*a' -exec rm {} +
+}