summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-12-24 09:55:16 +0000
committerAchim Gottinger <achim@gentoo.org>2000-12-24 09:55:16 +0000
commit13aecd5d9b1226b01f53d8d9da0a32df068dd398 (patch)
tree14e1c220fbfe80dd6fa27ec7570ac4284f4232dc
parentfixed (finally!) bootdisk (diff)
downloadhistorical-13aecd5d9b1226b01f53d8d9da0a32df068dd398.tar.gz
historical-13aecd5d9b1226b01f53d8d9da0a32df068dd398.tar.bz2
historical-13aecd5d9b1226b01f53d8d9da0a32df068dd398.zip
FHS 2.1 fixes
-rw-r--r--sys-apps/baselayout/baselayout-1.4.ebuild6
-rw-r--r--sys-apps/bzip2/bzip2-1.0.1.ebuild3
-rw-r--r--sys-apps/gzip/gzip-1.2.4a-r1.ebuild8
-rw-r--r--sys-apps/net-tools/net-tools-1.57-r1.ebuild8
-rw-r--r--sys-apps/sed/sed-3.02.80.ebuild3
-rw-r--r--sys-apps/setserial/setserial-2.17-r1.ebuild5
-rw-r--r--sys-apps/tar/tar-1.13.18.ebuild4
-rw-r--r--sys-libs/cracklib/cracklib-2.7-r1.ebuild3
-rw-r--r--sys-libs/pam/pam-0.72-r1.ebuild3
-rw-r--r--sys-libs/pwdb/pwdb-0.61-r2.ebuild8
-rw-r--r--sys-libs/readline/readline-4.1-r1.ebuild13
-rw-r--r--sys-libs/slang/slang-1.4.2.ebuild3
12 files changed, 40 insertions, 27 deletions
diff --git a/sys-apps/baselayout/baselayout-1.4.ebuild b/sys-apps/baselayout/baselayout-1.4.ebuild
index 60e45ece68f6..73be1ab1e720 100644
--- a/sys-apps/baselayout/baselayout-1.4.ebuild
+++ b/sys-apps/baselayout/baselayout-1.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.4.ebuild,v 1.3 2000/12/23 00:32:16 drobbins Exp $# Copyright 1999-2000 Gentoo Technologies, Inc.
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.4.ebuild,v 1.4 2000/12/24 09:55:16 achim Exp $# Copyright 1999-2000 Gentoo Technologies, Inc.
A=""
S=${WORKDIR}/${P}
@@ -11,9 +11,9 @@ HOMEPAGE="http://www.gentoo.org"
src_install()
{
- if [ "$MAINTAINER" != "Y" ]
+ if [ "$MAINTAINER" != "yes" ]
then
- echo '!!! baselayout should only be merged if you know what you\'re doing.'
+ echo '!!! baselayout should only be merged if you know what youre doing.'
echo '!!! It will overwrite important system files (passwd/group and others) with their'
echo '!!! original versions. For now, please update your files by hand by'
echo '!!! comparing the contents of the files in '${FILESDIR}' to your'
diff --git a/sys-apps/bzip2/bzip2-1.0.1.ebuild b/sys-apps/bzip2/bzip2-1.0.1.ebuild
index cb38ab23f849..2f86b36eb9de 100644
--- a/sys-apps/bzip2/bzip2-1.0.1.ebuild
+++ b/sys-apps/bzip2/bzip2-1.0.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bzip2/bzip2-1.0.1.ebuild,v 1.7 2000/11/30 23:14:31 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bzip2/bzip2-1.0.1.ebuild,v 1.8 2000/12/24 09:55:16 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -39,6 +39,7 @@ src_install() {
try make PREFIX=${D}/usr install
into /usr
dolib.so libbz2.so.1.0.1
+ mv ${D}/usr/bin ${D}
preplib /usr
}
diff --git a/sys-apps/gzip/gzip-1.2.4a-r1.ebuild b/sys-apps/gzip/gzip-1.2.4a-r1.ebuild
index eb627b6277c4..00a547736ba5 100644
--- a/sys-apps/gzip/gzip-1.2.4a-r1.ebuild
+++ b/sys-apps/gzip/gzip-1.2.4a-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gzip/gzip-1.2.4a-r1.ebuild,v 1.6 2000/11/30 23:14:33 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gzip/gzip-1.2.4a-r1.ebuild,v 1.7 2000/12/24 09:55:16 achim Exp $
P=gzip-1.2.4a
A=${P}.tar.gz
@@ -15,14 +15,14 @@ RDEPEND="$DEPEND
>=sys-apps/bash-2.04"
src_compile() {
- try ./configure --host=${CHOST} --prefix=/usr
+ try ./configure --host=${CHOST} --prefix=/usr --exec-prefix=/
try pmake
}
src_install() {
dodir /usr/bin
- try make prefix=${D}/usr install
- cd ${D}/usr/bin
+ try make prefix=${D}/usr exec_prefix=${D}/ install
+ cd ${D}/bin
for i in gzexe zforce zgrep zmore znew zcmp
do
cp ${i} ${i}.orig
diff --git a/sys-apps/net-tools/net-tools-1.57-r1.ebuild b/sys-apps/net-tools/net-tools-1.57-r1.ebuild
index 9514306642ba..801ac527b514 100644
--- a/sys-apps/net-tools/net-tools-1.57-r1.ebuild
+++ b/sys-apps/net-tools/net-tools-1.57-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/net-tools/net-tools-1.57-r1.ebuild,v 1.6 2000/12/01 21:58:45 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/net-tools/net-tools-1.57-r1.ebuild,v 1.7 2000/12/24 09:55:16 achim Exp $
P=net-tools-1.57
A=${P}.tar.bz2
@@ -28,7 +28,11 @@ src_unpack() {
src_install() {
try make BASEDIR=${D} install
- mv ${D}/bin/* ${D}/sbin
+ mv ${D}/bin/* ${D}/sbin
+ for i in hostname domainname netstat
+ do
+ mv ${D}/sbin/${i} ${D}/bin
+ done
dodoc COPYING README README.ipv6 TODO
}
diff --git a/sys-apps/sed/sed-3.02.80.ebuild b/sys-apps/sed/sed-3.02.80.ebuild
index fe59a9f65623..87beae9313cc 100644
--- a/sys-apps/sed/sed-3.02.80.ebuild
+++ b/sys-apps/sed/sed-3.02.80.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-3.02.80.ebuild,v 1.4 2000/11/30 23:14:34 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-3.02.80.ebuild,v 1.5 2000/12/24 09:55:16 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -18,6 +18,7 @@ src_install() {
into /usr
doinfo doc/sed.info
doman doc/sed.1
+ into /
dobin sed/sed
dodoc COPYING NEWS README* THANKS TODO AUTHORS BUGS ANNOUNCE
}
diff --git a/sys-apps/setserial/setserial-2.17-r1.ebuild b/sys-apps/setserial/setserial-2.17-r1.ebuild
index cc422ca33cb0..cd5974f82ed7 100644
--- a/sys-apps/setserial/setserial-2.17-r1.ebuild
+++ b/sys-apps/setserial/setserial-2.17-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/setserial/setserial-2.17-r1.ebuild,v 1.6 2000/11/30 23:14:34 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/setserial/setserial-2.17-r1.ebuild,v 1.7 2000/12/24 09:55:16 achim Exp $
P=setserial-2.17
A=${P}.tar.gz
@@ -18,8 +18,9 @@ src_compile() {
}
src_install() {
+ into /
+ dobin setserial
into /usr
- dosbin setserial
doman setserial.8
dodoc README
docinto txt
diff --git a/sys-apps/tar/tar-1.13.18.ebuild b/sys-apps/tar/tar-1.13.18.ebuild
index eccd863f09a0..1b787b7258d0 100644
--- a/sys-apps/tar/tar-1.13.18.ebuild
+++ b/sys-apps/tar/tar-1.13.18.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tar/tar-1.13.18.ebuild,v 1.2 2000/11/30 23:14:35 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tar/tar-1.13.18.ebuild,v 1.3 2000/12/24 09:55:16 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -18,6 +18,8 @@ src_compile() {
src_install() {
cd ${S}
try make DESTDIR=${D} install
+ dodir /bin
+ mv ${D}/usr/bin/tar ${D}/bin/tar
dodoc AUTHORS ChangeLog* COPYING NEWS README* PORTS THANKS
}
diff --git a/sys-libs/cracklib/cracklib-2.7-r1.ebuild b/sys-libs/cracklib/cracklib-2.7-r1.ebuild
index a5796fbbe823..ca5f2df7b1db 100644
--- a/sys-libs/cracklib/cracklib-2.7-r1.ebuild
+++ b/sys-libs/cracklib/cracklib-2.7-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.7-r1.ebuild,v 1.8 2000/11/30 23:14:00 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.7-r1.ebuild,v 1.9 2000/12/24 09:55:16 achim Exp $
A=cracklib2_2.7.orig.tar.gz
A0=${P}-redhat.patch
@@ -33,6 +33,7 @@ src_install() {
dodir /usr/include
dodir /usr/share/cracklib
ROOT=${D} try make DICTPATH=\"/usr/share/cracklib/pw_dict\" install
+ mv ${D}/usr/lib ${D}
preplib /usr
dodoc HISTORY LICENCE MANIFEST POSTER README
}
diff --git a/sys-libs/pam/pam-0.72-r1.ebuild b/sys-libs/pam/pam-0.72-r1.ebuild
index 895386caf3d6..8e0725663fce 100644
--- a/sys-libs/pam/pam-0.72-r1.ebuild
+++ b/sys-libs/pam/pam-0.72-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.72-r1.ebuild,v 1.7 2000/11/30 23:14:00 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.72-r1.ebuild,v 1.8 2000/12/24 09:55:16 achim Exp $
P=pam-0.72
A=Linux-PAM-0.72.tar.gz
@@ -19,6 +19,7 @@ src_unpack() {
touch .freezemake
rm default.defs
sed -e "s/CFLAGS=.*/CFLAGS=${CFLAGS} -pipe -D_REENTRANT/" \
+ -e "s:LIBDIR=.*:LIBDIR=/lib:" \
-e "s:FAKEROOT=.*:FAKEROOT=${D}:" defs/linux.defs > default.defs
echo "EXTRALS=-lcrypt" >> default.defs
cp Makefile Makefile.orig
diff --git a/sys-libs/pwdb/pwdb-0.61-r2.ebuild b/sys-libs/pwdb/pwdb-0.61-r2.ebuild
index 8fde74a6330c..9601ff1eb8f7 100644
--- a/sys-libs/pwdb/pwdb-0.61-r2.ebuild
+++ b/sys-libs/pwdb/pwdb-0.61-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/pwdb-0.61-r2.ebuild,v 1.2 2000/11/30 23:14:00 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/pwdb-0.61-r2.ebuild,v 1.3 2000/12/24 09:55:16 achim Exp $
P=pwdb-0.61
A=${P}.tar.gz
@@ -29,7 +29,7 @@ src_install() {
cd ${S}
into /usr
dodir /usr/include/pwdb
- dodir /usr/lib
+ dodir /lib
dodoc CHANGES Copyright CREDITS README
docinto html
dodoc doc/html/*
@@ -37,8 +37,8 @@ src_install() {
dodoc doc/*.txt
insinto /etc
doins conf/pwdb.conf
- try make INCLUDED=${D}/usr/include/pwdb LIBDIR=${D}/usr/lib LDCONFIG="echo" install
- preplib /usr
+ try make INCLUDED=${D}/usr/include/pwdb LIBDIR=${D}/lib LDCONFIG="echo" install
+ preplib /
cd ${O}/files
insinto /etc/pam.d
diff --git a/sys-libs/readline/readline-4.1-r1.ebuild b/sys-libs/readline/readline-4.1-r1.ebuild
index 76c100c3ee82..515dc0ff0f34 100644
--- a/sys-libs/readline/readline-4.1-r1.ebuild
+++ b/sys-libs/readline/readline-4.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.1-r1.ebuild,v 1.7 2000/12/01 02:04:21 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.1-r1.ebuild,v 1.8 2000/12/24 09:55:16 achim Exp $
P=readline-4.1
A=${P}.tar.gz
@@ -33,12 +33,13 @@ src_install() {
dodoc doc/*.ps
docinto html
dodoc doc/*.html
- dosym libhistory.so.4.1 /usr/lib/libhistory.so
- dosym libreadline.so.4.1 /usr/lib/libreadline.so
+ mv ${D}/usr/lib ${D}
+ dosym libhistory.so.4.1 /lib/libhistory.so
+ dosym libreadline.so.4.1 /lib/libreadline.so
# Needed because make install uses ${D} for the link
- dosym libhistory.so.4.1 /usr/lib/libhistory.so.4
- dosym libreadline.so.4.1 /usr/lib/libreadline.so.4
- chmod 755 ${D}/usr/lib/*.4.1
+ dosym libhistory.so.4.1 /lib/libhistory.so.4
+ dosym libreadline.so.4.1 /lib/libreadline.so.4
+ chmod 755 ${D}/lib/*.4.1
}
diff --git a/sys-libs/slang/slang-1.4.2.ebuild b/sys-libs/slang/slang-1.4.2.ebuild
index 758bcfd70d7b..7181da92df4b 100644
--- a/sys-libs/slang/slang-1.4.2.ebuild
+++ b/sys-libs/slang/slang-1.4.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.2.ebuild,v 1.4 2000/11/30 23:14:00 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.2.ebuild,v 1.5 2000/12/24 09:55:16 achim Exp $
P=slang-1.4.2
A=${P}.tar.gz
@@ -25,6 +25,7 @@ src_unpack() {
src_install() {
try make ${MAKEOPTS} prefix=${D}/usr install-elf
+ mv ${D}/usr/lib ${D}
preplib /usr
rm -rf ${D}/usr/doc/slang
dodoc COPYING* NEWS README *.txt