summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-07 15:51:46 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-07 15:51:46 +0000
commit245a0c78f9deb073cbfb9093661d2c4fc337e720 (patch)
tree0f161248e80db6b7de4222ccd264f795a8312863
parentAdded a stratscript (diff)
downloadhistorical-245a0c78f9deb073cbfb9093661d2c4fc337e720.tar.gz
historical-245a0c78f9deb073cbfb9093661d2c4fc337e720.tar.bz2
historical-245a0c78f9deb073cbfb9093661d2c4fc337e720.zip
Added a startscript
-rw-r--r--x11-wm/WindowMaker/WindowMaker-0.62.1-r1.ebuild9
-rwxr-xr-xx11-wm/WindowMaker/files/windowmaker3
-rwxr-xr-xx11-wm/fvwm/files/fvwm3
-rw-r--r--x11-wm/fvwm/fvwm-2.3.28.ebuild6
-rwxr-xr-xx11-wm/icewm/files/icewm3
-rw-r--r--x11-wm/icewm/icewm-1.0.8-r4.ebuild2
6 files changed, 19 insertions, 7 deletions
diff --git a/x11-wm/WindowMaker/WindowMaker-0.62.1-r1.ebuild b/x11-wm/WindowMaker/WindowMaker-0.62.1-r1.ebuild
index 7d5985b84ef9..5b4a49330f0e 100644
--- a/x11-wm/WindowMaker/WindowMaker-0.62.1-r1.ebuild
+++ b/x11-wm/WindowMaker/WindowMaker-0.62.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/WindowMaker/WindowMaker-0.62.1-r1.ebuild,v 1.4 2000/11/02 08:31:54 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/WindowMaker/WindowMaker-0.62.1-r1.ebuild,v 1.5 2001/05/07 15:51:46 achim Exp $
P=WindowMaker-0.62.1
A="${P}.tar.gz WindowMaker-extra-0.1.tar.bz2"
@@ -20,7 +20,6 @@ DEPEND=">=sys-libs/glibc-2.1.3
>=x11-base/xfree-4.0.1"
src_compile() {
- cd ${S}
try ./configure --host=${CHOST} --prefix=/usr/X11R6 --sysconfdir=/etc/X11 \
--enable-gnome --enable-kde --with-x --enable-newstyle --enable-superfluous
try make
@@ -30,17 +29,15 @@ src_compile() {
}
src_install() {
- cd ${S}
try make prefix=${D}/usr/X11R6 sysconfdir=${D}/etc/X11 install
+ exeinto /usr/X11R6/bin/wm
+ doexe ${FILESDIR}/windowmaker
cp -f WindowMaker/plmenu ${D}/etc/X11/WindowMaker/WMRootMenu
- strip ${D}/usr/X11R6/bin/*
- strip ${D}/usr/X11R6/GNUstep/Apps/WPrefs.app/WPrefs
dodoc AUTHORS BUGFORUM BUGS ChangeLog COPYING* FAQ* README* NEWS TODO
cd ../WindowMaker-extra-0.1
try make prefix=${D}/usr/X11R6 install
newdoc README README.extra
- prepman /usr/X11R6
diff --git a/x11-wm/WindowMaker/files/windowmaker b/x11-wm/WindowMaker/files/windowmaker
new file mode 100755
index 000000000000..717deeb8fded
--- /dev/null
+++ b/x11-wm/WindowMaker/files/windowmaker
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /usr/X11R6/bin/wmaker
diff --git a/x11-wm/fvwm/files/fvwm b/x11-wm/fvwm/files/fvwm
new file mode 100755
index 000000000000..251c4fa3c1f8
--- /dev/null
+++ b/x11-wm/fvwm/files/fvwm
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /usr/X11R6/bin/fvwm2
diff --git a/x11-wm/fvwm/fvwm-2.3.28.ebuild b/x11-wm/fvwm/fvwm-2.3.28.ebuild
index 87e34915a464..89fb7e2bddaa 100644
--- a/x11-wm/fvwm/fvwm-2.3.28.ebuild
+++ b/x11-wm/fvwm/fvwm-2.3.28.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Peter Gavin <pete@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.3.28.ebuild,v 1.1 2001/03/02 03:32:14 pete Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.3.28.ebuild,v 1.2 2001/05/07 15:45:41 achim Exp $
#P=
A=${P}.tar.bz2
@@ -27,5 +27,9 @@ src_compile() {
}
src_install () {
+
try make DESTDIR=${D} install
+ exeinto /usr/X11R6/bin/wm
+ doexe ${FILESDIR}/fvwm
+
}
diff --git a/x11-wm/icewm/files/icewm b/x11-wm/icewm/files/icewm
new file mode 100755
index 000000000000..e73ee39adebb
--- /dev/null
+++ b/x11-wm/icewm/files/icewm
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /usr/X11R6/bin/icewm
diff --git a/x11-wm/icewm/icewm-1.0.8-r4.ebuild b/x11-wm/icewm/icewm-1.0.8-r4.ebuild
index beb24a6e7f4a..738f53c1118a 100644
--- a/x11-wm/icewm/icewm-1.0.8-r4.ebuild
+++ b/x11-wm/icewm/icewm-1.0.8-r4.ebuild
@@ -16,6 +16,8 @@ src_compile(){
src_install(){
try make prefix=${D}/usr/X11R6 DOCDIR=${S}/dummy install
+ exeinto /usr/X11R6/bin/wm
+ doexe ${FILESDIR}/icewm
dodoc BUGS CHANGES COPYING FAQ PLATFORMS README TODO VERSION
docinto html
dodoc doc/*.html