summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-10-24 03:24:45 +0000
committerMike Frysinger <vapier@gentoo.org>2012-10-24 03:24:45 +0000
commit28f42c9a2e0bc6c68cf73634fdaad2b470effc80 (patch)
tree42816289f7b0c882cc42d20983647b6cd82f34bb
parentVersion bump, by jbergstroem. (diff)
downloadhistorical-28f42c9a2e0bc6c68cf73634fdaad2b470effc80.tar.gz
historical-28f42c9a2e0bc6c68cf73634fdaad2b470effc80.tar.bz2
historical-28f42c9a2e0bc6c68cf73634fdaad2b470effc80.zip
install more libiberty headers #439286 by Hristo Venev
-rw-r--r--eclass/toolchain-binutils.eclass14
1 files changed, 12 insertions, 2 deletions
diff --git a/eclass/toolchain-binutils.eclass b/eclass/toolchain-binutils.eclass
index 84d373a6759c..fce928131fdc 100644
--- a/eclass/toolchain-binutils.eclass
+++ b/eclass/toolchain-binutils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain-binutils.eclass,v 1.119 2012/10/17 19:14:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain-binutils.eclass,v 1.120 2012/10/24 03:24:45 vapier Exp $
#
# Maintainer: Toolchain Ninjas <toolchain@gentoo.org>
#
@@ -357,7 +357,17 @@ toolchain-binutils_src_install() {
fi
fi
insinto ${INCPATH}
- doins "${S}/include/libiberty.h"
+ local libiberty_headers=(
+ # Not all the libiberty headers. See libiberty/Makefile.in:install_to_libdir.
+ demangle.h
+ dyn-string.h
+ fibheap.h
+ hashtab.h
+ libiberty.h
+ objalloc.h
+ splay-tree.h
+ )
+ doins "${libiberty_headers[@]/#/${S}/include/}" || die
if [[ -d ${D}/${LIBPATH}/lib ]] ; then
mv "${D}"/${LIBPATH}/lib/* "${D}"/${LIBPATH}/
rm -r "${D}"/${LIBPATH}/lib