summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-04 20:13:49 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-04 20:13:49 +0000
commit6008c0845834baff5c38e1af3a0ab54023353bd5 (patch)
treef943547e8b6cc0220619726fcebd8a246476e5a3
parentVersion bump (diff)
downloadhistorical-6008c0845834baff5c38e1af3a0ab54023353bd5.tar.gz
historical-6008c0845834baff5c38e1af3a0ab54023353bd5.tar.bz2
historical-6008c0845834baff5c38e1af3a0ab54023353bd5.zip
Revert static-libs handling, #406905; push changes from 8.5.10 to .11
Package-Manager: portage-2.2.0_alpha89/cvs/Linux x86_64
-rw-r--r--dev-lang/tcl/ChangeLog6
-rw-r--r--dev-lang/tcl/tcl-8.5.10.ebuild10
-rw-r--r--dev-lang/tcl/tcl-8.5.11.ebuild33
-rw-r--r--dev-lang/tk/ChangeLog6
-rw-r--r--dev-lang/tk/tk-8.5.10.ebuild5
-rw-r--r--dev-lang/tk/tk-8.5.11.ebuild21
6 files changed, 42 insertions, 39 deletions
diff --git a/dev-lang/tcl/ChangeLog b/dev-lang/tcl/ChangeLog
index ab93ef2eddd6..1e7f8278cef2 100644
--- a/dev-lang/tcl/ChangeLog
+++ b/dev-lang/tcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/tcl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.145 2012/03/02 19:39:57 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.146 2012/03/04 20:11:13 jlec Exp $
+
+ 04 Mar 2012; Justin Lecher <jlec@gentoo.org> tcl-8.5.10.ebuild,
+ tcl-8.5.11.ebuild:
+ Revert static-libs handling, #406905; push changes from 8.5.10 to .11
02 Mar 2012; Brent Baude <ranger@gentoo.org> tcl-8.5.10.ebuild:
Marking tcl-8.5.10 ppc64 for bug 406607
diff --git a/dev-lang/tcl/tcl-8.5.10.ebuild b/dev-lang/tcl/tcl-8.5.10.ebuild
index 0e389dcdb44d..bc144bf96990 100644
--- a/dev-lang/tcl/tcl-8.5.10.ebuild
+++ b/dev-lang/tcl/tcl-8.5.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.10.ebuild,v 1.5 2012/03/02 19:39:57 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.10.ebuild,v 1.6 2012/03/04 20:11:13 jlec Exp $
EAPI=4
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/tcl/${MY_P}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x86-solaris"
-IUSE="debug static-libs threads"
+IUSE="debug threads"
S="${WORKDIR}/${MY_P}"
@@ -95,11 +95,7 @@ src_install() {
# install symlink for libraries
dosym libtcl${v1}$(get_libname) /usr/${mylibdir}/libtcl$(get_libname)
- if use static-libs; then
- dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a
- else
- rm -f "${ED}"/usr/${mylibdir}/*.a || die
- fi
+ dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a
dosym tclsh${v1} /usr/bin/tclsh
diff --git a/dev-lang/tcl/tcl-8.5.11.ebuild b/dev-lang/tcl/tcl-8.5.11.ebuild
index 463b16884ac8..5a52d4ab8e6a 100644
--- a/dev-lang/tcl/tcl-8.5.11.ebuild
+++ b/dev-lang/tcl/tcl-8.5.11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.11.ebuild,v 1.1 2012/03/02 15:30:44 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.11.ebuild,v 1.2 2012/03/04 20:11:13 jlec Exp $
-EAPI="3"
+EAPI=4
inherit autotools eutils flag-o-matic multilib toolchain-funcs
@@ -21,13 +21,13 @@ S="${WORKDIR}/${MY_P}"
pkg_setup() {
if use threads ; then
- ewarn ""
+ echo
ewarn "PLEASE NOTE: You are compiling ${P} with"
ewarn "threading enabled."
ewarn "Threading is not supported by all applications"
ewarn "that compile against tcl. You use threading at"
ewarn "your own discretion."
- ewarn ""
+ echo
fi
}
@@ -59,8 +59,7 @@ src_configure() {
}
src_compile() {
- cd "${S}"/unix
- emake || die
+ cd "${S}"/unix && emake
}
src_install() {
@@ -69,7 +68,7 @@ src_install() {
v1=${PV%.*}
cd "${S}"/unix
- S= emake DESTDIR="${D}" install || die
+ S= emake DESTDIR="${D}" install
# fix the tclConfig.sh to eliminate refs to the build directory
local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
@@ -83,34 +82,34 @@ src_install() {
[[ ${CHOST} != *-darwin* && ${CHOST} != *-mint* ]] && sed -i \
-e "s,^TCL_CC_SEARCH_FLAGS='\(.*\)',TCL_CC_SEARCH_FLAGS='\1:${EPREFIX}/usr/${mylibdir}'," \
-e "s,^TCL_LD_SEARCH_FLAGS='\(.*\)',TCL_LD_SEARCH_FLAGS='\1:${EPREFIX}/usr/${mylibdir}'," \
- "${ED}"/usr/${mylibdir}/tclConfig.sh
+ "${ED}"/usr/${mylibdir}/tclConfig.sh || die
# install private headers
insinto /usr/${mylibdir}/tcl${v1}/include/unix
- doins "${S}"/unix/*.h || die
+ doins "${S}"/unix/*.h
insinto /usr/${mylibdir}/tcl${v1}/include/generic
- doins "${S}"/generic/*.h || die
- rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tcl.h
- rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclDecls.h
- rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclPlatDecls.h
+ doins "${S}"/generic/*.h
+ rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tcl.h || die
+ rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclDecls.h || die
+ rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclPlatDecls.h || die
# install symlink for libraries
dosym libtcl${v1}$(get_libname) /usr/${mylibdir}/libtcl$(get_libname) || die
dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a || die
- dosym tclsh${v1} /usr/bin/tclsh || die
+ dosym tclsh${v1} /usr/bin/tclsh
cd "${S}"
- dodoc ChangeLog* README changes || die
+ dodoc ChangeLog* README changes
}
pkg_postinst() {
- ewarn
+ echo
ewarn "If you're upgrading from <dev-lang/tcl-8.5, you must recompile the other"
ewarn "packages on your system that link with tcl after the upgrade"
ewarn "completes. To perform this action, please run revdep-rebuild"
ewarn "in package app-portage/gentoolkit."
ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
ewarn "upgrade them before this recompilation, too,"
- ewarn
+ echo
}
diff --git a/dev-lang/tk/ChangeLog b/dev-lang/tk/ChangeLog
index baa60aa5349f..d0432d6a1b20 100644
--- a/dev-lang/tk/ChangeLog
+++ b/dev-lang/tk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/tk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.158 2012/03/02 20:20:05 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.159 2012/03/04 20:13:49 jlec Exp $
+
+ 04 Mar 2012; Justin Lecher <jlec@gentoo.org> tk-8.5.10.ebuild,
+ tk-8.5.11.ebuild:
+ Revert static-libs handling, #406905; push changes from 8.5.10 to .11
02 Mar 2012; Brent Baude <ranger@gentoo.org> tk-8.5.10.ebuild:
Marking tk-8.5.10 ppc64 for bug 406607
diff --git a/dev-lang/tk/tk-8.5.10.ebuild b/dev-lang/tk/tk-8.5.10.ebuild
index 204cccbd1d02..7bc5b1b4596d 100644
--- a/dev-lang/tk/tk-8.5.10.ebuild
+++ b/dev-lang/tk/tk-8.5.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.5.10.ebuild,v 1.3 2012/03/02 20:20:05 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.5.10.ebuild,v 1.4 2012/03/04 20:13:49 jlec Exp $
EAPI=4
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/tcl/${MY_P}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug static-libs threads truetype aqua xscreensaver"
+IUSE="debug threads truetype aqua xscreensaver"
RDEPEND="
!aqua? (
@@ -102,6 +102,7 @@ src_install() {
# install symlink for libraries
#dosym libtk${v1}.a /usr/${mylibdir}/libtk.a
dosym libtk${v1}$(get_libname) /usr/${mylibdir}/libtk$(get_libname)
+ dosym libtkstub${v1}.a /usr/${mylibdir}/libtkstub.a
if use static-libs; then
dosym libtkstub${v1}.a /usr/${mylibdir}/libtkstub.a
diff --git a/dev-lang/tk/tk-8.5.11.ebuild b/dev-lang/tk/tk-8.5.11.ebuild
index 0a9cc6c0fe80..7bd6fad9794c 100644
--- a/dev-lang/tk/tk-8.5.11.ebuild
+++ b/dev-lang/tk/tk-8.5.11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.5.11.ebuild,v 1.1 2012/03/02 15:31:00 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.5.11.ebuild,v 1.2 2012/03/04 20:13:49 jlec Exp $
-EAPI="3"
+EAPI=4
inherit autotools eutils multilib toolchain-funcs prefix
@@ -61,8 +61,7 @@ src_configure() {
}
src_compile() {
- cd "${S}"/unix
- emake || die
+ cd "${S}"/unix && emake
}
src_install() {
@@ -71,7 +70,7 @@ src_install() {
v1=${PV%.*}
cd "${S}"/unix
- S= emake DESTDIR="${D}" install || die
+ S= emake DESTDIR="${D}" install
# normalize $S path, bug #280766 (pkgcore)
local nS="$(cd "${S}"; pwd)"
@@ -94,20 +93,20 @@ src_install() {
# install private headers
insinto /usr/${mylibdir}/tk${v1}/include/unix
- doins "${S}"/unix/*.h || die
+ doins "${S}"/unix/*.h
insinto /usr/${mylibdir}/tk${v1}/include/generic
- doins "${S}"/generic/*.h || die
+ doins "${S}"/generic/*.h
rm -f "${ED}"/usr/${mylibdir}/tk${v1}/include/generic/tk.h
rm -f "${ED}"/usr/${mylibdir}/tk${v1}/include/generic/tkDecls.h
rm -f "${ED}"/usr/${mylibdir}/tk${v1}/include/generic/tkPlatDecls.h
# install symlink for libraries
#dosym libtk${v1}.a /usr/${mylibdir}/libtk.a
- dosym libtk${v1}$(get_libname) /usr/${mylibdir}/libtk$(get_libname) || die
- dosym libtkstub${v1}.a /usr/${mylibdir}/libtkstub.a || die
+ dosym libtk${v1}$(get_libname) /usr/${mylibdir}/libtk$(get_libname)
+ dosym libtkstub${v1}.a /usr/${mylibdir}/libtkstub.a
- dosym wish${v1} /usr/bin/wish || die
+ dosym wish${v1} /usr/bin/wish
cd "${S}"
- dodoc ChangeLog* README changes || die
+ dodoc ChangeLog* README changes
}