summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKito Danya Dietrich <kito@gentoo.org>2004-09-27 20:03:14 +0000
committerKito Danya Dietrich <kito@gentoo.org>2004-09-27 20:03:14 +0000
commit74c4c8a2e8c3371d05a67ae90a695fb35d9d97a1 (patch)
tree2be9b615ec8b886748f8ddc3364bb5303e030f7b
parentStable on sparc (diff)
downloadhistorical-74c4c8a2e8c3371d05a67ae90a695fb35d9d97a1.tar.gz
historical-74c4c8a2e8c3371d05a67ae90a695fb35d9d97a1.tar.bz2
historical-74c4c8a2e8c3371d05a67ae90a695fb35d9d97a1.zip
more syntax cleanup
-rw-r--r--sys-apps/bootstrap_cmds/Manifest2
-rw-r--r--sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild31
2 files changed, 16 insertions, 17 deletions
diff --git a/sys-apps/bootstrap_cmds/Manifest b/sys-apps/bootstrap_cmds/Manifest
index a48359253cf9..0ece3c398e66 100644
--- a/sys-apps/bootstrap_cmds/Manifest
+++ b/sys-apps/bootstrap_cmds/Manifest
@@ -1,4 +1,4 @@
MD5 a5f2512be3bc798344df9dba19131918 ChangeLog 331
-MD5 e7850cf18bf34c446d0faaa677e7ee43 bootstrap_cmds-44.ebuild 1566
+MD5 dca9b2809221fa2a211a73f87b714623 bootstrap_cmds-44.ebuild 1676
MD5 65d0ad2167dd016e2981b7a3df82cc50 metadata.xml 212
MD5 476b98a9a8f0ba1fccda9ccdd2a58edc files/digest-bootstrap_cmds-44 69
diff --git a/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild b/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild
index 2e8af1c9bcb7..90148b983bd2 100644
--- a/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild
+++ b/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild,v 1.4 2004/09/27 18:39:23 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild,v 1.5 2004/09/27 20:03:14 kito Exp $
DESCRIPTION="Darwin bootstrap_cmds - config, decomment, mig, relpath"
HOMEPAGE="http://darwinsource.opendarwin.org/10.3.5/"
@@ -22,7 +22,6 @@ DEPEND="virtual/libc"
BUILDARCHS="ppc"
pkg_setup() {
- mkdir -p ${WORKDIR}/build/obj ${WORKDIR}/build/sym ${S}/BUILD
export RC_OS=macos
export RC_ARCHS=${BUILDARCHS}
export TARGETS=${BUILDARCHS}
@@ -33,29 +32,29 @@ pkg_setup() {
export RC_CFLAGS="${CFLAGS}"
}
-src_compile() {
- cd ${S}
- emake || die "make failed"
-}
-
-src_install() {
- cd ${S}
+src_unpack() {
+ unpack ${A}
+ mkdir -p ${WORKDIR}/build/obj ${WORKDIR}/build/sym ${S}/BUILD
rm ${S}/Makefile.postamble
rm ${S}/config.tproj/Makefile.postamble
rm ${S}/decomment.tproj/Makefile.postamble
rm ${S}/relpath.tproj/Makefile.postamble
+}
+
+src_compile() {
+ emake || die "make failed"
+}
- make install DSTROOT=${S}/BUILD
+src_install() {
+ make install DSTROOT=${S}/BUILD || die "make install failed"
- dobin ${S}/BUILD/usr/bin/config
- newbin ${S}/migcom.tproj/mig.sh mig
- newbin ${S}/vers_string.sh vers_string
- dobin ${S}/BUILD/usr/local/bin/decomment
- dobin ${S}/BUILD/usr/local/bin/relpath
+ newbin ${S}/migcom.tproj/mig.sh mig || die "newbin mig failed"
+ newbin ${S}/vers_string.sh vers_string || die "newbin vers_string failed"
+ dobin ${S}/BUILD/usr/local/bin/{decomment,relpath} ${S}/BUILD/usr/bin/config \
+ || die "dobin decomment, relpath, config failed"
exeinto /usr/libexec
doexe ${S}/BUILD/usr/libexec/migcom
- cd ${S}
doman ${S}/vers_string.1
} \ No newline at end of file