summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-04-23 21:13:25 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-04-23 21:13:25 +0000
commit7e4a397a0b2a38b811fed1a10d1f0e36b5e90f98 (patch)
treea9b8dc1af9eaf8d0de925c00b70472ebdb8b8e08
parentFixing Betelgeuse's name and minor cleanups (diff)
downloadhistorical-7e4a397a0b2a38b811fed1a10d1f0e36b5e90f98.tar.gz
historical-7e4a397a0b2a38b811fed1a10d1f0e36b5e90f98.tar.bz2
historical-7e4a397a0b2a38b811fed1a10d1f0e36b5e90f98.zip
Fix for bug #90153.
Package-Manager: portage-2.0.51.19
-rw-r--r--sys-apps/sandbox/ChangeLog7
-rw-r--r--sys-apps/sandbox/Manifest14
-rw-r--r--sys-apps/sandbox/files/digest-sandbox-1.2.11
-rw-r--r--sys-apps/sandbox/sandbox-1.2.1.ebuild73
4 files changed, 93 insertions, 2 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index 133f7efbfe65..c0179d61600c 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sandbox
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.2 2005/04/23 13:14:08 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.3 2005/04/23 21:13:25 azarah Exp $
+
+*sandbox-1.2.1 (23 Apr 2005)
+
+ 23 Apr 2005; Martin Schlemmer <azarah@gentoo.org> +sandbox-1.2.1.ebuild:
+ Fix for bug #90153.
*sandbox-1.2 (Apr 23 2005)
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index cdbc26ab2566..ef3344fbd4ba 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -1,4 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 9fd5eb46e8da4d0e78fa40bc39f3b602 ChangeLog 523
MD5 968e2965b0b6f620634dae6d28d8b4c4 metadata.xml 455
MD5 fa4e917c828593f1c202fe11f019e2d3 sandbox-1.2.ebuild 1711
-MD5 fc9394af165f666cbca8a6e286fdc292 ChangeLog 397
+MD5 47438c0ad7e347064cdaf223d6a5f042 sandbox-1.2.1.ebuild 1747
MD5 06ad9881ad2610487c66565ee5b39389 files/digest-sandbox-1.2 64
+MD5 9b60e9e6d1e45533a0e719fdf023ec07 files/digest-sandbox-1.2.1 66
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCart01ZcsMnZjRyIRAmNiAJ4kJu3RSxqB1zvpakFrlUOmBUih+wCgsdE9
+6ROu5LkOxLk14PvmrEWEaDM=
+=TJvK
+-----END PGP SIGNATURE-----
diff --git a/sys-apps/sandbox/files/digest-sandbox-1.2.1 b/sys-apps/sandbox/files/digest-sandbox-1.2.1
new file mode 100644
index 000000000000..6cdf0c26f8f5
--- /dev/null
+++ b/sys-apps/sandbox/files/digest-sandbox-1.2.1
@@ -0,0 +1 @@
+MD5 233586e779d83a260cb747c982acdaa2 sandbox-1.2.1.tar.bz2 220410
diff --git a/sys-apps/sandbox/sandbox-1.2.1.ebuild b/sys-apps/sandbox/sandbox-1.2.1.ebuild
new file mode 100644
index 000000000000..d17541fbc58a
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-1.2.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.1.ebuild,v 1.1 2005/04/23 21:13:25 azarah Exp $
+
+inherit eutils flag-o-matic eutils toolchain-funcs multilib
+#
+# don't monkey with this ebuild unless contacting portage devs.
+# period.
+#
+
+IUSE=""
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~azarah/sandbox/${P}.tar.bz2"
+DEPEND=""
+LICENSE="GPL-2"
+SLOT='0'
+
+#KEYWORDS=" alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 s390 sh sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+src_unpack() {
+ if has_multilib_profile; then
+ for TA in $(get_install_abis); do
+ unpack ${A} || die "unpack failed"
+ cd ${S}
+ epunt_cxx
+ cd ..
+ mv ${S} ${S%/}-${TA} || die "failed mving \$S to $TA"
+ done
+ else
+ unpack ${A} || die "unpack failed"
+ cd ${S}
+ epunt_cxx
+ fi
+}
+
+src_compile() {
+ if has_multilib_profile; then
+ OABI="${ABI}"
+ export CFLAGS="${CFLAGS} -DSB_HAVE_64BIT_ARCH"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ econf || die "econf failed for $ABI"
+ emake || die "emake failed for $ABI"
+ done
+ ABI="${OABI}"
+ else
+ if useq amd64; then
+ check_multilib
+ export CFLAGS="${CFLAGS} -DSB_HAVE_64BIT_ARCH=${MULTILIB}"
+ fi
+ cd ${S}
+ econf || die "econf failed"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ if has_multilib_profile; then
+ OABI="${ABI}"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ einstall || die "einstall failed for $ABI"
+ done
+ ABI="${OABI}"
+ else
+ cd ${S}
+ einstall || die "einstalled failed"
+ fi
+}