summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-11 23:31:26 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-11 23:31:26 +0000
commit7f0d761d2ee34ddd2100dc3d7bc011778f9d37de (patch)
treeed69f524d4bd9f3639c0be44236cf68ddd666d4b
parentNew patchset by Anthony G Basile, based on mainline 2.6.32.15 sources. (diff)
downloadhistorical-7f0d761d2ee34ddd2100dc3d7bc011778f9d37de.tar.gz
historical-7f0d761d2ee34ddd2100dc3d7bc011778f9d37de.tar.bz2
historical-7f0d761d2ee34ddd2100dc3d7bc011778f9d37de.zip
Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-HEAD/cvs/Linux x86_64
-rw-r--r--dev-python/pycipher/ChangeLog8
-rw-r--r--dev-python/pycipher/Manifest4
-rw-r--r--dev-python/pycipher/pycipher-0.2.ebuild33
3 files changed, 29 insertions, 16 deletions
diff --git a/dev-python/pycipher/ChangeLog b/dev-python/pycipher/ChangeLog
index 42f0caa8613b..e091d1b333ff 100644
--- a/dev-python/pycipher/ChangeLog
+++ b/dev-python/pycipher/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pycipher
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycipher/ChangeLog,v 1.1 2009/02/03 19:55:22 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycipher/ChangeLog,v 1.2 2010/06/11 23:31:26 arfrever Exp $
+
+ 11 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pycipher-0.2.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*pycipher-0.2 (03 Feb 2009)
diff --git a/dev-python/pycipher/Manifest b/dev-python/pycipher/Manifest
index 09ac11d2938a..42b1a8b0908a 100644
--- a/dev-python/pycipher/Manifest
+++ b/dev-python/pycipher/Manifest
@@ -1,4 +1,4 @@
DIST pycipher-0.2.py 9174 RMD160 c7a4e058c90fac367a8c21bb6ec3a66a061ccf31 SHA1 8abea9736209bc6bb6224a4c5071f2b6d4b62a0b SHA256 c9acccea93d8f469b0b577f0dcbf4bbaf8a95c869a1c6b75d9e39c55e60e47e1
-EBUILD pycipher-0.2.ebuild 793 RMD160 ccb731938305dd960e200fb0a216961d26ecd0a4 SHA1 d30b75d45814b894f1d61dd28f32cbab63637b47 SHA256 8e1c357089408191dfde7e5803ca2c8eb1b80ea3aa1d13956852d82b7196bc14
-MISC ChangeLog 419 RMD160 0ff56a42be48a0a224d5c6c7e337e3fd70303b93 SHA1 9650e9c0d6b0f9171caee4bab8a2a92eab42e724 SHA256 4ee3139b985770fb40f87d2eca402fc626d7b1bfde59e5aeec1256f7e8602e23
+EBUILD pycipher-0.2.ebuild 796 RMD160 def525e68326e7af22b74949541a8454f6aa1dc8 SHA1 30f669b8a0a9154e090dace53c540f23e7f7bb17 SHA256 0f8c1e488b2e7580fe879fe9623012784f1fa0e77ea19ba21134eca10a8e6cd1
+MISC ChangeLog 544 RMD160 2f18e2634b2078b05eb6de48c08efc4b483d6dc7 SHA1 74d8d516797a98ef6f143d460c2effba0c8fbb0e SHA256 0e77b6fc061bda0bcee5b6696dfe16736843ff5325e07c12e66e05b9a4ee7f3a
MISC metadata.xml 160 RMD160 e730f96ab97c5be577a6d6d05f04990374a0dffb SHA1 2aa5e6be9c265c0e7bceb78ee9fd20df5f818e36 SHA256 6cd954a9de2307c57d32b25fa3599dee2908a4ddc6a98594f593d53577307a3a
diff --git a/dev-python/pycipher/pycipher-0.2.ebuild b/dev-python/pycipher/pycipher-0.2.ebuild
index 1313bc20b7d1..2036ae4332f7 100644
--- a/dev-python/pycipher/pycipher-0.2.ebuild
+++ b/dev-python/pycipher/pycipher-0.2.ebuild
@@ -1,11 +1,14 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycipher/pycipher-0.2.ebuild,v 1.1 2009/02/03 19:55:22 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycipher/pycipher-0.2.ebuild,v 1.2 2010/06/11 23:31:26 arfrever Exp $
-inherit eutils python
+EAPI="3"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
-DESCRIPTION="A Python module that implements several well-known classical cipher \
-algorithms"
+inherit python
+
+DESCRIPTION="A Python module that implements several well-known classical cipher algorithms"
HOMEPAGE="http://pycipher.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.py"
@@ -14,15 +17,21 @@ SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE=""
-DEPEND="dev-lang/python"
+DEPEND=""
+RDEPEND=""
src_install() {
- cd "${WORKDIR}"
+ installation() {
+ insinto $(python_get_sitedir)
+ newins "${DISTDIR}/${P}.py" ${PN}.py
+ }
+ python_execute_function installation
+}
- python_version
- exeinto "${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages"
- newexe "${DISTDIR}/${P}.py ${PN}.py"
+pkg_postinst() {
+ python_mod_optimize ${PN}.py
+}
- local dir="${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages"
- make_wrapper "${PN}" "python ./${PN}.py" "${dir}"
+pkg_postrm() {
+ python_mod_cleanup ${PN}.py
}