summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2006-01-14 07:51:23 +0000
committerHarald van Dijk <truedfx@gentoo.org>2006-01-14 07:51:23 +0000
commit828252a33e7e88c45ee094193c4373b54107b2ac (patch)
tree2ee9d9cc2a58e727ed6b6e8f3b1bda423246f2af
parentstable on x86 as per bug #118946 (diff)
downloadhistorical-828252a33e7e88c45ee094193c4373b54107b2ac.tar.gz
historical-828252a33e7e88c45ee094193c4373b54107b2ac.tar.bz2
historical-828252a33e7e88c45ee094193c4373b54107b2ac.zip
Clarifying error message for bug #67524
Package-Manager: portage-2.1_pre3-r1
-rw-r--r--dev-util/dialog/ChangeLog9
-rw-r--r--dev-util/dialog/Manifest10
-rw-r--r--dev-util/dialog/dialog-1.0.20051107.ebuild14
3 files changed, 24 insertions, 9 deletions
diff --git a/dev-util/dialog/ChangeLog b/dev-util/dialog/ChangeLog
index d5e9dce1402c..879171638bc8 100644
--- a/dev-util/dialog/ChangeLog
+++ b/dev-util/dialog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/dialog
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/ChangeLog,v 1.58 2005/11/21 13:34:22 truedfx Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/ChangeLog,v 1.59 2006/01/14 07:51:22 truedfx Exp $
+
+ 14 Jan 2006; Harald van Dijk <truedfx@gentoo.org>
+ dialog-1.0.20051107.ebuild:
+ unicode flag requires wide ncurses, immediately die with a clearer error
+ message if that's not available (bug #67524)
21 Nov 2005; Harald van Dijk <truedfx@gentoo.org>
dialog-1.0.20051107.ebuild:
diff --git a/dev-util/dialog/Manifest b/dev-util/dialog/Manifest
index c36f680afcdb..961fb7672f6c 100644
--- a/dev-util/dialog/Manifest
+++ b/dev-util/dialog/Manifest
@@ -1,10 +1,10 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 94a1125faad7ad0c1160643ead24f587 ChangeLog 8665
+MD5 27a43d46f6f7fd2c1bac461a6cb46526 ChangeLog 8870
MD5 cd7bc4ff18512a7738ebc9c7c50a2006 dialog-1.0.20050206.ebuild 1013
MD5 87305276830661f174d9c290ea1b1028 dialog-1.0.20050306.ebuild 924
-MD5 23c96ccd1e690ba5a18dffedd7585507 dialog-1.0.20051107.ebuild 1081
+MD5 3d0b976460e2094a374891699a8eab6a dialog-1.0.20051107.ebuild 1488
MD5 516258483f8caafb1bbad3ca633b2a74 files/dialog-1.0.20051107-mouseselect.patch 664
MD5 0fb57e331af29543a80113129d8d6585 files/digest-dialog-1.0.20050206 76
MD5 6bb2fe6f496b5c53063dfb1f6971021d files/digest-dialog-1.0.20050306 76
@@ -12,7 +12,7 @@ MD5 8ad8276b29c5f6ffcc0e746acfc02844 files/digest-dialog-1.0.20051107 76
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDgc0OwnQyISwouHwRAvOCAKC4hBdoDDVUNFwUMutrAGrEku+zsQCfQv7g
-ZPkUvxN1Bccd/2uXKHorURM=
-=l+lH
+iD8DBQFDyK3pwnQyISwouHwRAh6gAJ46IqGqN/yFMIhvxsOn9CclU9Wf4QCffJui
+6Br8fEI2pXKkBWMYk6JpDsg=
+=TWZe
-----END PGP SIGNATURE-----
diff --git a/dev-util/dialog/dialog-1.0.20051107.ebuild b/dev-util/dialog/dialog-1.0.20051107.ebuild
index 0a3feaebdbf3..56d2a1f1fbd0 100644
--- a/dev-util/dialog/dialog-1.0.20051107.ebuild
+++ b/dev-util/dialog/dialog-1.0.20051107.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/dialog-1.0.20051107.ebuild,v 1.2 2005/11/21 13:34:22 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/dialog-1.0.20051107.ebuild,v 1.3 2006/01/14 07:51:23 truedfx Exp $
inherit eutils
@@ -18,6 +18,16 @@ IUSE="examples unicode"
DEPEND=">=app-shells/bash-2.04-r3
>=sys-libs/ncurses-5.2-r5"
+pkg_setup() {
+ if use unicode && ! built_with_use sys-libs/ncurses unicode; then
+ eerror "Installing dialog with the unicode flag requires ncurses be"
+ eerror "built with it as well. Please make sure your /etc/make.conf"
+ eerror "or /etc/portage/package.use enables it, and re-install"
+ eerror "ncurses with \`emerge --oneshot sys-libs/ncurses\`."
+ die "Re-emerge ncurses with the unicode flag"
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"