summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-01-25 12:03:29 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-01-25 12:03:29 +0000
commitebcd05f12d403485e27b51f32a228f8984e69a04 (patch)
tree4d893c016765847facdd5b0c37872f6ce8d67e0c
parentcleanup (diff)
downloadhistorical-ebcd05f12d403485e27b51f32a228f8984e69a04.tar.gz
historical-ebcd05f12d403485e27b51f32a228f8984e69a04.tar.bz2
historical-ebcd05f12d403485e27b51f32a228f8984e69a04.zip
curses and kde based tools for browsing streaming audio. ebuild provided by me. closes bug #23598
-rw-r--r--media-sound/radiostation/ChangeLog11
-rw-r--r--media-sound/radiostation/Manifest3
-rw-r--r--media-sound/radiostation/metadata.xml5
-rw-r--r--media-sound/radiostation/radiostation-0.5.ebuild49
4 files changed, 68 insertions, 0 deletions
diff --git a/media-sound/radiostation/ChangeLog b/media-sound/radiostation/ChangeLog
new file mode 100644
index 000000000000..4595627ecb7c
--- /dev/null
+++ b/media-sound/radiostation/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-sound/radiostation
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/radiostation/ChangeLog,v 1.1 2004/01/25 12:03:21 eradicator Exp $
+
+*radiostation-0.5 (25 Jan 2004)
+
+ 25 Jan 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ radiostation-0.5.ebuild:
+ curses and kde based tools for browsing streaming audio. ebuild provided by
+ me. closes bug #23598
+
diff --git a/media-sound/radiostation/Manifest b/media-sound/radiostation/Manifest
new file mode 100644
index 000000000000..cfa7cd7bf10c
--- /dev/null
+++ b/media-sound/radiostation/Manifest
@@ -0,0 +1,3 @@
+MD5 7ea0172d2ec0c4b3f4dfa7f7bf8bd2aa ChangeLog 454
+MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
+MD5 f4ed0051bf9e68464965061712752d34 radiostation-0.5.ebuild 1363
diff --git a/media-sound/radiostation/metadata.xml b/media-sound/radiostation/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/radiostation/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/radiostation/radiostation-0.5.ebuild b/media-sound/radiostation/radiostation-0.5.ebuild
new file mode 100644
index 000000000000..3da255f6a5aa
--- /dev/null
+++ b/media-sound/radiostation/radiostation-0.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/radiostation/radiostation-0.5.ebuild,v 1.1 2004/01/25 12:03:21 eradicator Exp $
+
+DESCRIPTION="Managements system for online audio streams"
+HOMEPAGE="http://mindx.dyndns.org/kde/radio/"
+LICENSE="GPL-2"
+
+IUSE="debug kde"
+
+# We don't inherit kde-base because we might not need to install the kde
+# related components, and if that's the case, we don't want to accidently
+# pull in kde as a dependency
+
+DEPEND="kde? ( >=kde-base/kdelibs-3.1 )
+ dev-util/dialog
+ net-www/lynx
+ net-misc/wget
+ media-sound/xmms"
+
+KEYWORDS="~x86 ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~mips ~alpha ~arm ~hppa"
+
+S=${WORKDIR}/kderadiostation-${PV}
+SRC_URI="http://mindx.dyndns.org/kde/radio/source/kderadiostation-${PV}.tar.gz
+ http://mindx.dyndns.org/kde/radio/source/radiostation"
+
+src_unpack() {
+ if [ `use kde` ]; then
+ unpack kderadiostation-${PV}.tar.gz
+ fi
+
+ cp ${DISTDIR}/radiostation ${WORKDIR}
+}
+
+src_compile() {
+ if [ `use kde` ]; then
+ econf `use_enable debug` || die "Unsuccessful configure"
+ emake || die "Unsuccessful make"
+ fi
+}
+
+src_install() {
+ if [ `use kde` ]; then
+ einstall || die "Unsuccessful install"
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+ fi
+
+ dobin ${WORKDIR}/radiostation
+}