summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamon Conway <kabau@gentoo.org>2002-01-09 20:34:45 +0000
committerDamon Conway <kabau@gentoo.org>2002-01-09 20:34:45 +0000
commitfe4f87e256a079ed1048c690ddac94fa3c02a5f9 (patch)
treef934615eb44bc3b96cf2e6818086f136486d9a8e
parentnew version (diff)
downloadhistorical-fe4f87e256a079ed1048c690ddac94fa3c02a5f9.tar.gz
historical-fe4f87e256a079ed1048c690ddac94fa3c02a5f9.tar.bz2
historical-fe4f87e256a079ed1048c690ddac94fa3c02a5f9.zip
Adding the split tcl/tk ebuilds. They appear to work just fine.
-rw-r--r--dev-lang/tcl/files/digest-tcl-8.3.31
-rw-r--r--dev-lang/tcl/tcl-8.3.3.ebuild67
-rw-r--r--dev-lang/tk/files/digest-tk-8.3.31
-rw-r--r--dev-lang/tk/tk-8.3.3.ebuild68
4 files changed, 137 insertions, 0 deletions
diff --git a/dev-lang/tcl/files/digest-tcl-8.3.3 b/dev-lang/tcl/files/digest-tcl-8.3.3
new file mode 100644
index 000000000000..661616e66cb1
--- /dev/null
+++ b/dev-lang/tcl/files/digest-tcl-8.3.3
@@ -0,0 +1 @@
+MD5 e94397490adb2c1c2b1990052b1a92b2 tcl8.3.3.tar.gz 2592768
diff --git a/dev-lang/tcl/tcl-8.3.3.ebuild b/dev-lang/tcl/tcl-8.3.3.ebuild
new file mode 100644
index 000000000000..5450ad76649b
--- /dev/null
+++ b/dev-lang/tcl/tcl-8.3.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/dev-lang/tcl-tk/tcl-tk-8.4.2.ebuild,v 1.7 2001/11/10 11:31:53 hallski Exp
+
+
+S=${WORKDIR}/${PN}${PV}
+SRC_URI="ftp://ftp.scriptics.com/pub/tcl/tcl8_4/${PN}${PV}.tar.gz"
+
+
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+
+DESCRIPTION="Tool Command Language"
+
+DEPEND="virtual/glibc"
+
+# hyper-optimizations untested...
+#
+
+src_compile() {
+
+ cd ${S}/unix
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-threads || die
+
+ emake CFLAGS="${CFLAGS}" || die
+
+}
+
+src_install() {
+
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tclConfig.sh to eliminate refs to the build directory
+ sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L${S}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='${S}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ ${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
+ mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tcl${v1}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tcl${v1}/include/unix
+ dodir /usr/lib/tcl${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tcl${v1}/include/generic
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tcl.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclDecls.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
+
+ # install symlink for libraries
+ dosym /usr/lib/libtcl${v1}.a /usr/lib/libtcl.a
+ dosym /usr/lib/libtclstub${v1}.a /usr/lib/libtclstub.a
+
+ ln -sf tclsh${v1} ${D}/usr/bin/tclsh
+
+ cd ${S}
+ dodoc README changes license.terms
+
+}
diff --git a/dev-lang/tk/files/digest-tk-8.3.3 b/dev-lang/tk/files/digest-tk-8.3.3
new file mode 100644
index 000000000000..b9d9db6424e0
--- /dev/null
+++ b/dev-lang/tk/files/digest-tk-8.3.3
@@ -0,0 +1 @@
+MD5 72eb2d4a84f32fc1608e2333f92a2661 tk8.3.3.tar.gz 2539520
diff --git a/dev-lang/tk/tk-8.3.3.ebuild b/dev-lang/tk/tk-8.3.3.ebuild
new file mode 100644
index 000000000000..1949d1c8ada0
--- /dev/null
+++ b/dev-lang/tk/tk-8.3.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/dev-lang/tcl-tk/tcl-tk-8.4.2.ebuild,v 1.7 2001/11/10 11:31:53 hallski Exp
+
+
+S=${WORKDIR}/${PN}${PV}
+SRC_URI="ftp://ftp.scriptics.com/pub/tcl/tcl8_4/${PN}${PV}.tar.gz"
+
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+
+DESCRIPTION="Tk Widget Set"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ =dev-lang/tcl-${PV}"
+
+# hyper-optimizations untested...
+#
+src_compile() {
+
+ cd ${S}/unix
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-tcl=/usr/lib \
+ --enable-threads || die
+
+ emake CFLAGS="${CFLAGS}" || die
+
+}
+
+src_install() {
+
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tkConfig.sh to eliminate refs to the build directory
+ sed -e "s,^TK_BUILD_LIB_SPEC='-L${S2}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TK_SRC_DIR='${S2}',TCL_SRC_DIR='/usr/lib/tk${V2}/include'," \
+ -e "s,^TK_BUILD_STUB_LIB_SPEC='-L${S2}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TK_BUILD_STUB_LIB_PATH='${S2}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ ${D}/usr/lib/tkConfig.sh > ${D}/usr/lib/tkConfig.sh.new
+ mv ${D}/usr/lib/tkConfig.sh.new ${D}/usr/lib/tkConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tk${V2}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tk${v1}/include/unix
+ dodir /usr/lib/tk${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tk${v1}/include/generic
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tk.h
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tkDecls.h
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tkPlatDecls.h
+
+ # install symlink for libraries
+ dosym /usr/lib/libtk${v1}.a /usr/lib/libtk.a
+ dosym /usr/lib/libtkstub${v1}.a /usr/lib/libtkstub.a
+
+ ln -sf wish${v1} ${D}/usr/bin/wish
+
+ cd ${S}
+ dodoc README changes license.terms
+
+}