summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2004-04-22 07:42:42 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2004-04-22 07:42:42 +0000
commit94aa88ae32223bf0234c112e53823e356ad39e60 (patch)
treebecee892a3f0402e64228df379f694a28c263d65 /app-accessibility/gnopernicus/gnopernicus-0.8.4.ebuild
parentget the patch off the Debian mirrors; update to the latest Debian patch. (diff)
downloadhistorical-94aa88ae32223bf0234c112e53823e356ad39e60.tar.gz
historical-94aa88ae32223bf0234c112e53823e356ad39e60.tar.bz2
historical-94aa88ae32223bf0234c112e53823e356ad39e60.zip
New release
Diffstat (limited to 'app-accessibility/gnopernicus/gnopernicus-0.8.4.ebuild')
-rw-r--r--app-accessibility/gnopernicus/gnopernicus-0.8.4.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-accessibility/gnopernicus/gnopernicus-0.8.4.ebuild b/app-accessibility/gnopernicus/gnopernicus-0.8.4.ebuild
new file mode 100644
index 000000000000..3e68d1376fdf
--- /dev/null
+++ b/app-accessibility/gnopernicus/gnopernicus-0.8.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnopernicus/gnopernicus-0.8.4.ebuild,v 1.1 2004/04/22 07:42:42 leonardop Exp $
+
+inherit eutils gnome2
+
+IUSE="${IUSE} ipv6"
+# Local USE flags
+IUSE="${IUSE} brltty"
+
+DESCRIPTION="Software tools for blind and visually impaired in Gnome 2"
+HOMEPAGE="http://www.baum.ro/gnopernicus.html"
+
+SLOT="1"
+KEYWORDS="~x86 ~sparc ~hppa ~alpha ~ia64 ~ppc ~amd64"
+LICENSE="LGPL-2"
+
+# libgail-gnome is only required during runtime
+
+RDEPEND=">=gnome-base/gconf-1.1.5
+ >=dev-libs/popt-1.5
+ >=gnome-base/libgnome-1.102
+ >=gnome-base/libgnomeui-1.106
+ >=dev-libs/glib-1.3.12
+ >=x11-libs/gtk+-1.3
+ >=dev-libs/libxml2-2.4.6
+ >=gnome-base/libglade-1.99.4
+ >=gnome-extra/at-spi-1.3.11
+ >=app-accessibility/gnome-speech-0.3
+ >=app-accessibility/gnome-mag-0.9
+ >=gnome-extra/libgail-gnome-1.0
+ virtual/x11
+ brltty? ( app-accessibility/brltty )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.29
+ dev-util/pkgconfig
+ app-text/scrollkeeper"
+
+G2CONF="${G2CONF} --with-default-fonts-path=${D}/usr/share/fonts/default/Type1"
+G2CONF="${G2CONF} $(use_enable ipv6) $(use_enable brltty)"
+
+DOCS="AUTHORS ChangeLog COPYING NEWS README"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Patch to make it work with any version of brltty.
+ epatch ${FILESDIR}/${P}-brltty_fix.patch
+}