summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2004-02-23 12:12:07 +0000
committerAkinori Hattori <hattya@gentoo.org>2004-02-23 12:12:07 +0000
commit725ce90dfd7b1c99f9d5c5b97351dd7ccec3db3c (patch)
tree295ec724c25ac2b622d6fb181c399f2e42c4e504 /app-admin/chrootuid/chrootuid-1.3.ebuild
parentmarking ~alpha (diff)
downloadhistorical-725ce90dfd7b1c99f9d5c5b97351dd7ccec3db3c.tar.gz
historical-725ce90dfd7b1c99f9d5c5b97351dd7ccec3db3c.tar.bz2
historical-725ce90dfd7b1c99f9d5c5b97351dd7ccec3db3c.zip
Initial revision. Ebuild submitted by Michael C. Ferguson <mcf@augustmail.com> in bug #40981.
Diffstat (limited to 'app-admin/chrootuid/chrootuid-1.3.ebuild')
-rw-r--r--app-admin/chrootuid/chrootuid-1.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/chrootuid/chrootuid-1.3.ebuild b/app-admin/chrootuid/chrootuid-1.3.ebuild
new file mode 100644
index 000000000000..4286f0c2cada
--- /dev/null
+++ b/app-admin/chrootuid/chrootuid-1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chrootuid/chrootuid-1.3.ebuild,v 1.1 2004/02/23 12:12:07 hattya Exp $
+
+IUSE=""
+
+MY_P="${P/-/}"
+
+DESCRIPTION="Chrootuid makes it easy to run a network service at low privilege level and with restricted file system access."
+HOMEPAGE="ftp://ftp.porcupine.org/pub/security/index.html"
+SRC_URI="ftp://ftp.porcupine.org/pub/security/${MY_P}.tar.gz"
+
+RESTRICT="nomirror"
+LICENSE="BSD"
+KEYWORDS="~x86"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ # Add in our own custom CFLAGS
+ sed -i "s/CFLAGS\t=/CFLAGS = ${CFLAGS} #/" Makefile
+ emake || die "emake failed :'("
+}
+
+src_install() {
+ dobin chrootuid
+ doman chrootuid.1
+ dodoc README chrootuid_license
+}